Blender deleting vertices that ARE NOT doubles.

Every now and then I select all the vertices in the model I am working on with the A key, then pull up the submenu using the W key, and select “remove all doubles” which removes extra vertices (vertices lying on the exact same position as another vertex). Recently when I do this, Blender has started removing vertices that ARE NOT doubles, which alters the look of the model drastically. Anyone have any idea what may have happened? I’m guessing I may have pressed a key and changed some default setting. Any help is greatly appreciated.

Remove doubles merges vertices that are closer than the “Threshold” distance. This should come up at the bottom of the tools panel when you press remove doubles.
Alter this distance and you should get the result you are going for.