Blender Dev support regarding GPU, Cuda error, or kernel error

For Over 3 months I have tried everything even clean install of windows to get Blender3D to work with 1070 and 2070 GPU as they all worked fine with 2.8 all way up to 2.92 then 2.93 hit and Nothing works

Better GPU Support all Round Blender is focusing on Newer cards and not backward compatibility, which is pushing normal hobby users out of using the software until they own an RTX 3000 or 4000, Too many people all over every forum have to mess about with settings to get 1070 cards or 2070 cards to work and lately found RTX3000 users having issues when they worked fine before,
It’s like what MAX3d did to push people to buy more hardware, Stop the commercial approach of hardware upgrades to work with Blender. If you don’t have the latest card Fine it will run slower but, too many people getting Kernel errors or Cuda errors. and the Dev team just ignores the bug reports and always blames the user, and the user does everything they say and is still buggy as hell. Remember 90% of #hobby Blender users are the ones who spend money on #add-ons for a blender. Is Blender Tutorial/addon/ #Youtube #Comunity willing to lose Revenue from Views/Sales/Addons because #BlenderDev’s is not listening to the many just the Few?

Maybe there should be one Forum Topic that everyone uploads the GPU error as Blender is not dealing with it when it’s reported to them. as I found out a joe blogs user on the Reporting Bugs site will ask you questions that takes you out the line of assigning the issues, and when you reply if you don’t click a set box to throw it back to the Dev team your bug issue is marked as solved, I know it won’t count for much but i canceled my #subscription to #blender3d, after 3 years as felt they didn’t need my #support as I found no support returned to me, just frustration.

Sorry for the Rant but I loved Blender and feel I’m forced to problem solve what the Dev team ignores, I’m not the only person having GPU issues?

Just stick to 2.8 until you can get a new GPU? This thread should be moved to discussion, this is a rant not news.


srry I’m out of the loop but I have a 1660S and optix and cuda rendering works fine. (sure I may run out of vram every once in a while) can I ask what is not working?

Hi, Cuda and Optix are working fine on Windows 10/11 and Linux with a RTX 2060. Driver 371 studio on Windows, 360 on Linux.
Did the 2070 work alone?

Cheers, mib

Can you please give more info such as what error you are getting? Have you reported any bug in relation to this? The devs can’t fix issues if they don’t know about them.

I only have the 2070 card in the PC, yes it works for a little while then after a few hours the error shows up so I have to shut down Blender and then re-run it,

The strange part is if i use the AMD ProRender no issues no glitches no drama

Here are the system requirements for blender and as AMD Pro Render works fine no glitches. as my GPU is 8 gig and RTX family should work fine.

by the way strange how your opinion matters, when a fault was posted in the right area. you see fit to pick one Word of “Rant” and place it where you like. you picked the one word that suits your objective. read full system requirements of Blender and other posts on the same errors before you play judge and post monitor.


Thanks for the reply is the Dev Support number, ive posted every screen shot, and done everything they asked me to do.

Now it sits in limbo and no way forward, you will see that just a basic default cube.

Thanks for your reply


Topic moved to #general-forums:blender-and-cg-discussions


basic Cube in GPU render and Cuda errors

This was posted in correct area, and as “son” flagged post to be moved strange, it was moved on the word “rant” not reviewed as a whole.

I never flag anything just suggested it moved from News to discussion. I didn’t even contact any mods to move it. Lastly it is a rant…

I am sure the moderator review your post before moving it :stuck_out_tongue:

This is not a common error. With thousands of Blender users having a similar problem this would be highly visible if it happened to everyone. So, if a handful of users are having this problem, it would be necessary to investigate why it occurs in this group of users.
If you say that you never have that kind of problem in 2.83 version, we should investigate what changed from 2.9x (as denoiser settings).
To rule out problems on your side, the ideal would be to try it in a different OS clean installation, installing only the nvidia driver (studio, not gaming on windows) and not installing any extra utility related to the GPU, such as those used for overclocking or cooling profiles. If you have any of those utilities installed on current OS, you uninstall them. Also try a newer version of the nvidia driver or previous version of the nvidia driver installed. Always checking do a clean install from nvidia installer. On windows you could try a clean uninstall with DDU, and then install a new driver:

And if you on that OS you had an AMD card before nvidia, you also check the options to remove AMD driver in DDU

1 Like

Me again.
Are these reports yours?

In one of them you mention having problems in all versions of Blender:

As I have said before, this is not at all common to happen. Have you considered having a hardware problem? Have you tried those same GPUs on another motherboard?

So what you are saying is, If my hardware works fine with Everything BUT Blender, It must be the user’s Hardware?

So as you got defensive I did loads of research before asking here I did not just pull out the air its a growing problem

Works fine with substance painter. works fine with max3d, So it must be the user
All these posts in the last year

Like I said in my post is did everything I was told to do and even rebuild windows from scratch

Is your c drive full?

No, and I use a separate hard drive to store all blender and 3D software
C drive has 400gig free space

Different types of CUDA errors have occurred since the beginning of Cycles. That doesn’t mean anything at all.
How much of these reports occur with Blender 2.9x and even with default cube, as it happens to you? How many on Windows? How many on Linux?
If you find a report with a problem similar to yours where it gives errors even with default cube without it being a complex scene, you should add to the report data from your hardware and the necessary information to try to deduce why this small group of users have this problem even with default cube scene.

Are they using CUDA/OptiX intensively?

Do you have any experience installing Linux with proprietary nvidia driver? Testing on Linux and depending on the result we could perhaps get some clues about the problem.

I used to have similar issues, it is a Blender thing IMO, like ever loading kernels, that will eventually load after some time :smiley: the drivers might also cause problems of course.
Try to update to the latest drivers, with a clean install. Make sure your settings are fine, you can even tell nvidia control to run blender exe, but it should not matter. Plus, I would suggest you simply try OptiX.
You can always turn it back and forth, or go to CPU render view, then back to GPU. Maybe to solid then back to rendered view, etc… Like pushing a car to turn the engine :smiley:
But seriously, as I experienced these issues come and go. If you roll with OptiX, it should work like charm, better actually, just try the above. If that is a similar issue, like I have sometimes, it will eventually disappear, and rarely come around again.

1 Like

2.93+ and 3.x work with 2070. You are not explaining how you are getting these errors. Most likely your scenes need optimizations to fit your assets into the memory.