Blender Developer Environment as Downloadable Appliance (VirtualBox)

Since there have been some requests for this I made a 670mb linux install thats setup to run an IDE and build blender right out of the box in VirtualBox (can run from Linux/OSX/Windows).

Wiki instructions and download link here.

Interested to know if this is helpful for new devs getting started, or if setting up a VirtualBox system is more trouble then simply installing dev tools natively on you’re system.

I like the concept. Testing it now.

i’m not a developers but i’m very interested to dive into developing. actually i do learn C a little bit. But there is no tutorials on the web about how to start development in blender.
This machine is perfect way to start! thanks so much

@@vitos1k I recently played with Blender’s code and I that was an eye opener. Some part of the code are not that hard to deal with even if my c/c++ was really rusty. I am mostly interested by the Collada part, to try to add some of the Collada’s extension to Blender.

@ideasman42: Thank for the Appliance and the Wiki - really useful I already used it to submit a patch.

That being said I have two minors issues:

a) In CMake I cannot enable OpenCollada. I get the following error message: “Could NOT find OpenCOLLADA (missing: _opencollada_LIBRARIES _opencollada_INCLUDES)”
b) I get a lot of flickering when I run Blender. I am on Mac OS X Lion and I am using the last virtualBox version with the Oracle extension. It’s obviously an issue with OpenGL. And I do get some warning message in the IDE about it. I am not using the VM right now but I will be sure to send you the error I get.

Thanks again for your work, I really appreciate it.

@ideasman42: Thanks from me as well. I have tried to setup a DEV environment on all three operating systems unsuccessfully. I imported your appliance into my Windows XP64 VirtualBox and successfully compiled Blender for the first time!

I did get one warning, however. (Blender still launched though).

Ok, I am playing around with some of the commands and I pulled down the latest with the svn up command. I clicked the hammer icon again to build the project. It compiled the same as last time. Now when I click the green arrow to launch Blender I get a custom executable dialog? Before, Blender just launched. Where is the executable? I tried to locate it by browsing, but I am not sure what folder it reside in.

@VisualFox. re-opencollada, for this youll need to grab linux/lib, or build opencollada from source.

Try grab from our svn…

cd ~/blender-svn
svn co lib/linux

as for flickering, not much we can do about this since its 99% sure not a blender bug,

@Atom, thats strange, it should not ask you again, nevertheless - heres the path to the executable…

Thank you! I will try the svn lib path. For the flickering I am sure that not related to blender but probably to OpenGL and VirtualBox. I do get these two warning when I run Blender:

OpenGL Warning: No pincher, please call crStateSetCurrentPointers() in your SPU
OpenGL Warning: No pincher, please call crStateSetCurrentPointers() in your SPU

a helpful tool, thank you


I am eventually going to take it for a test drive.

But I have to say that I really do not have a full understanding of VirtualBox and what is it’s advantages and disadvantages as well as setting it up on any given distro.

If anyone can make a quick post regarding the concept of VirtualBox, I would humbly appreciate it.

@animaguy, depends on what you’re comparing it against.

  • advantage, its a pre-built setup you can tinker with, but not have to go through installing development packages which can be a hassle, especially on some systems.

  • disadvantage, booting an entire virtualized OS is overkill, eventually you would want dev tools running natively I expect.

So this is just for new devs to get their feet wet, and also to become aware of what developing on linux can be like with a good IDE, I know some devs like emacs/vim, but these guys already know how to setup a good environment and wouldnt bother messing with this virtual environment anyway.

Though I must admit - now its done, Im pretty happy to have a blender dev environment on a small USB thumb drive I can take anywhere :D.

Also, arch-linux is known to be hard to use, but since this is pre-configured I expect that wont be an issue.

@ideasman42: Thanks for the path, that worked. I guess the executable was there all the while (it has a gear icon not Blebnder icon).

Do you have any tips on searching for specific code parts within the code base? For instance I am looking for the way the Particle system chooses randomly from groups when it’s render type is set to group and choose randomly. I have searched around in the code named particles and searched on ‘dupli’ but I still can’t locate that code section.


Sunday is the day I normally do not have access to my computer.

But since I have my smartphone I can get a lot of reading done.

I read your VirtualBox tut on the wiki.

That is an awesome tutorial.

I actually can’t wait to take a test drive.

I have been spending a lot of time installing linux distros, installing dependencies, downloading the source and building. It is very time consuming. But I believe it is important for me to become an expert at this because it really is the first step for new devs.

I don’t like leaving any stone unturned.

A couple of quick notes:

I was planning on eclipse but this is a great opportunity to learn QtCreator.

I have been studying configuring Arch and this will be nice to play on a pre-configured version while I learn.

I was exploring diff apps for Linux. I used winmerge when I was on Win7. So I it is awesome you included Meld by default.

Can’t wait to try it out.

So I set it up and now I have two proven methods to install a development environment.

Pretty sweet.

I think I need to take a break from serting up development environments and start learning the file systems.

Great job ideasman42.

So you know what this means?

It means we all wait for the next newbie blender dev to submit another post entitled:

“I want to be a blender developer but I don’t know how to get started”

so I tried to build the environment again on a fresh install.

and the when i opened the terninal i wanted to try and install firefox but there were issues.

i typed this command

ping -c 3

and i got an unknown host error message

basically the environment was offline and I do not know how to connect

I went back to the native install on the Linux Mint 13

I thought I would post as an fyi for future reference.

i briefly tried to reconfigure the network but decided i would just go to the native version for efficiency sake.

i am still new to arch

Thank you for you help. I did grab the lib from svn but only: boost ffmpeg ocio oiio were present. So I have to built openCollada myself…

@VisualFox - eek! my bad, I dont use lib/ from SVN,
Arch has an opencollada package, so this should work.

pacman -S opencollada


@animaguy, sorry I can’t help as far as virtualbox network issues go, other then to say that this is an issue on the host side (not the image), so this needs to be resovled by configuring virtualbox.
It worked for me on Ubuntu 12.04 with default virtualbox settings so not sure what you might change.

@ideasman42 Thank you! Works great now!

I have been recently experimenting with the ova file provided above and I just wanted to give another thank you.


You are a Rock Star, dude.