Blender does not select correct points in edit mode

In edit mode, when I click a point, Blender selects a different, unrelated point. When I use b->drag click it selects a random series of vertices. This happens for all primitives. I’ve tried reinstalling newer versions, going back to factory settings, and bought a new mouse. I’m working on a PC with Windows 7. What could be causing this problem and how can I fix it?

Thank you

This problem is reportedly due to having anti-aliasing enabled in the graphics driver (for some types of cards.) Try right-clicking your desktop and bring up the graphics control panel. Find anti-aliasing and turn it off. It should be possible to configure the control to only turn it off for Blender.

That was it! Thank you very much!