Blender doesn't read pen pressure as input [linux]


(Muhamad Mahdi Fahrresta Triananda P) #21

Sorry for late information. Yesterday I add a ticket in dev.blender and someone said that this bug will be done on tomorrow build… Thank you everyone

https://developer.blender.org/T58030


(English is not my native language) #22

This should be currently in buildbots builds if I have not calculated the time incorrectly.


(Muhamad Mahdi Fahrresta Triananda P) #23

Yeah, It’s working :slight_smile:


(Grimm) #24

Awesome, thanks Jens!! Works great on my tablet now as well. :laughing: No need to mess with the xorg conf.


(jensverwiebe) #25

I would say this is implementation dependent behaviour.
I have also an old wacon graffire4 and the newer xp-pen tablet.
In mint prefs it seems the last detected tablet takes over the functionality whereas
in blender the first found tablet device will work as expected.
Imho blender pentablet code does not support more then 1 pen/stylus.

You can simply compare to older builds if the behaviour changed.
Indeed the testing and fixes we do here are a bit academical, as nobody has all those different devices available for testing. So we have to wait a bit what comes out from the userbase. On the other hand wacom is so dominating, the expected reports are rare for sure.

Jens


(Tony) #26

First, sorry if this duplicates but I have searched and my issue seems a little different.

Using Ubuntu 18.04 & 18.10. With and without the Nvidia graphic driver enabled. Currently using the X.OrgXserver driver as the Nvidia driver seems to cause intermittant UI freezes on both.

My Wacom Intuos Pro tablet pressure stops working in Blender. Initially I thought it was simply never working except on the system settings Wacom Tablet “Test your settings”. But now I see that the pen pressure does work if I go to 2D animation directly from the Splash screen. I can use the pen as much as I like with pressure working as long as I do not touch any of the buttons (View, Strokes, etc.). I can minimize the window, move etc. which gives no problem. The pressure even stopped working when I had a message from the OS. Pressure still works in “Test your settings”. I have noted that when the pressure stops working there does seem to be a pause in the screen updates.

I have tried the various re-installation suggestions of the drivers etc. to no effect (assuming I’m doing it correctly). Opening directly from the home screen into a model in sculpt mode had pressure working on clay strips up until I tried to change size.

Once pressure stops, the only way to get it working (albeit for a limited time) is to reboot the laptop.

I have booted from a live installation, installed and run Blender but then pressure never works. This was to check that something I have added was causing the issue.

Your thoughts or a redirection would be much appreciated.


(Tony) #27

One addition. I have installed Gimp and the pressure works fine.


(jensverwiebe) #28

Cannot reproduce with graffire4.
All fine here.

Jens


(bloozguy) #29

I’m in the same boat with Ubuntu 18.04 LTS and a Wacom Intuos 4.
Pressure sensitivity works everywhere (Krita, GIMP, Settings Test) BUT not with Blender.
I have read about ‘solutions’ involving stopping and starting processes, rebooting and such but you can find people having this problem as far back as at least 2002. It’s like its part of Blender’s DNA.
It’s not that the tablet is unusable but pressure sensitivity is somewhat of a big deal.
I am frustrated and don’t know where to turn.
The problem is intrinsic to Blender but is it only Blender on Linux or Blender in general?


(Muhamad Mahdi Fahrresta Triananda P) #30

Sorry I couldn’t be much help. But if you can’t do to make something work (after doing some research and workaround), you may ask at developer forum support to make it work just like what I did. But you must be sure that there isn’t similar bug have reported.