Blender doesn't want to change bones in weight paint

So I’ve got my model all weight painted, and now I want to iron out the bugs, but every time I enter weight paint mode and try to select a bone, Blender switches back to object mode and selects the armature.
I have no idea why Blender’s behavior suddenly changed… Anyone know anything useful?

EDIT: Never mind, figured it out… Start in pose mode, with target bone selected. Right-click on your mesh, then switch to weight paint mode. Works fine.

If you select the bone in posemode then (without changing modes yourself) select the object you wish to paint, blender will switch to objectmode . Go to weight paint mode and paint that bone area.

I just realized that you can also just click on the vertex group you want (while in wheight paint mode) in order to edit it. Perhaps you have X-ray enabled for your armature? this could mean you select the armature instead of the vertex group.