Blender Edit Mode Performance

Do autosmooth set to 180 degrees have special performance case? Or there is any other way without 3x performance hit to have smoothing groups/hard edges on your HP mesh?

Wow guys! I had to try it, and the day has come, now we’re way better than 2.79!! FINALLY!!!

I did a quick test with a 7 subdivision applied on the default cube in a few builds:

2.79: 15 fps
2.83: 10 fps
3.0: 25 fps

i7 9750-H and GTX1650

I also noted there’s differences in speed wether you select the whole thing or not, so there’s some caching going on…
Also some weird things: If you hide the toolshelf I get a few more fps, so do I if I disable overlays completely, reaching 30fps in this scenario.

1 Like

And as I mentioned, the devs. are not done yet, we are not quite halfway through the sprint.

Will Blender become faster than 3DS Max, I do not know as it sets a pretty high bar. The number 2 spot though is probably in reach if more of the big bottlenecks crumble away (where one of them already has a patch for).


I am talking about editmode performance, not I/O. I/O performance would probably be another project (ie, moving common exporters/importers from Python to C++).

This is getting exciting! :laughing:

1 Like

I am not sure about select-and-drag-comparisons. My excitement is on the hold, because some problems wont show up in some easy tests.

Atm, I do retopology for a project. Blender performs well for some time.

(Using Blender 2.93 stable.)

( Checked Blender 3.0 Master now. Lags are still interrupting workflow. )

But suddenly, after some fluid edits, there comes a lag.
These lags wont show in simple performance tests, but they interrupt workflow and they kill focus.

I am glad edit-performance is tackled.

1 Like

Blender 2.79 / 3.0 sculpt dev branch 06/12/2021
1.7 million triangles.

Edit mode with soft selection

Blender 2.79 : 3.15 fps
Blender 3.0 : 3.99 fps (+25% speed)

Freeze duration before the selected vertices are moving
Blender 2.79 : 48 seconds
Blender 3.0 : 2 seconds


The selection in Houdini is made with faces? Because they are slower to move than vertices, I think you lose ~2fps.

I forgot, but subdivision performance is still behind :pensive:
So is autosmooth, I wonder if they could add a thresold setting in the preferences or in autosmooth so it gets turn off when it needs to…

I suspect (could be wrong) that some memory leak(s) are the culprit, you could try this, start editing, once you feel the lag, immediately, save, close and reopen blender, and see if the lag is gone, if so I think that would confirm my theory, if not then maybe something else is responsible.

Do you mean a memory overflow?

I am not sure this could be a memory overflow.
The blend file takes 11G memory from 32G. (I had to shrink voxel density to prevent memory few weeks ago. ) There is 20G memory roon.

But I am not sure you meant Memory Overflow. I could try save-and-reload. But … brrrh …. I will try, but I don’t have the nerves to do today. I already exhausted myself, trying to keep up focus against lags-interruptions.

By memory leak, I meant that there is some blender function/process/whatever going in a loop (when it shouldn’t) allocating more ram with each loop, until it eats up all available memory and crash/freeze/etc… and the “noticeable” lag after a certain period of time is kind of a sign leading to that.

Mh … you just described a memory overflow.

Lags happen with 20G free ram. It cannot be caused by memory overflow.

Watching Memory and CPU load. During lag, none of the cores showed any change in load (like some 100% warrior cores, while other cores enjoy a nap).

I dont notice CPU/GPU spike with htop or nvidia-smi. Not sure whats causing it.

Different ppl calling it different names, but anyway, if it isn’t a memory “something” then Idk what could be the cause.

If it is not CPU / GPU / Memory, maybe its something different?
I guess there is a suspect.

I had autosave (every 2 minutes). The file is huge. Each autosave might result in a lag.
Maybe autosave causes the lags?!

I disabled autosave for now …

1 Like

What are your system specs? In my test I had much better results compared to 2.79 - just no comparison, really, and I tested a 1.3 million poly object in a reasonably complex scene.

AMD Ryzen 9 3900X 12-Core 3.79 GHz
Geforce RTX 2070

Autosave definitely causes lag spikes for me when working with large files.


Odd. You have the same CPU as I have, and an even better GPU (mine is a 1080) Check this out:


This compares Blender 2.79 → Cinema4D V24–> to Blender Alpha v3.

No rotation this time, just moving the same geometry.

Blender v3 is a little over 3 times faster than 2.79 in this case. Not just 25%: 320% to be exact. And notice I was a bit messy in my selection in v3 compared to 2.79 and C4D (actually more is selected).

For fun I included Cinema4D 24 which now uses Direct X on Windows. 1fps versus Blender v3 alpha’s 2.5fps.

Not bad at all so far.

Interestingly enough the latest build compared to the one I used last time is again a notch faster in this test: 2.3fps vs 2.5fps.


Subdivision surfaces involve a different area of code with an entirely different set of bottlenecks (which these commits do not fix).

Subdivision bottlenecks are currently being tackled by another developer.