Blender Error message

What i have done is, baked my own texture layer using stencil layers so i can make map it to my UV’s.

When i load my image it often says

libpng error: Image width or height is zero in IHDR
libpng error: Image width or height is zero in IHDR
libpng error: Image width or height is zero in IHDR
etc…

or for some other large images, above 2000x2000 pixels.

any way i can avoid this?

are you using the latest revision from svn? or are you using the alpha 2 build from blender.org? if you are using an older version, then try a newer one from graphicall.org as I remember these problems in the past but I haven’t seen them lately.

I’m having the exact same problem and I’ve tried a number of the latest builds from both the blender main site and newer ones from graphicall. 2.53 seems to crash when I try to load ANY image. Whether it be for texture or background image.

My console also reads “stack smashing detected” which sounds kinda cool.

Or would be if it didn’t crash my Blend.

Hi All

I’m also getting these ‘libpng error: Image width or height is zero in IHDR’ errors
also it mentions unknown file format.

This happens everytime i try to load in a background image. the image loads and stays in for that session, but after i close and reopen the file the image has gone.

If i add the same image as a texture it will work fine.

Im using the 2.53 blender.org build.

same problem here,

using 2.53 64bit
screenshot is here
http://blenderartists.org/forum/showthread.php?t=193652

any word on this libpng error message?.. i get the exact same thing when i load a texture image. as long as i select UV as the mapping option before trying to load the image blender doesn’t crash instantly and i can get the image texture in… but if i try to load another image it crashes… or if i don’t select UV first… crash guaranteed.

i did a report at the bug tracker site, maybe u should do it also …

I get the error when trying to view any type of video clip or image in the video editor.

I,m using Blender 2.53 r30581. XP/sp2
This was from the Blender.org main site.

Any clue when a fix is available?
Thanks

sorry i havnt been online for a lil while, but downloading the new version from


worked for me
Goodluck guys