blender exit itself when i try to ...

blender 2.42a
Official 2.42a for Intel Pentium 4: P4, Xeon, Core Solo/Duo, Pentium 5/6/7/8xx and certain Celerons (SSE1/2/3)

gives me this error while trying the following
press KEYB
select the 6 tubes

blend file

It works ok for me (2.42a Win XP).

Does it crash every time on your machine?

Does b(ox) select work in other files?

Try saving it to a new file then opening that file, or creating a new file and appending the objects into a new file.


i tried a few more tests.
it seems that the error only exists if i b(ox) select on objects that are [F7] >> Draw Panel >> Draw Extra >> Wire.

if the Draw Extra isn’t wire, it doesn’t yields error.

Hmm, no errors for me, when I make the tubes Wire.

What kind of graphics card do you have? ATI by any chance? They are known to not get along with Blender. … Might be an opengl error.

The Bug tracker is here if you want to report it. (You’ll have to register for a free account first).


maybe it only happens on my pc :frowning: :frowning: :frowning:
using onboard vga sis.

maybe i would post a bug report if there is more than one people who face the same issue like me.

thanks a lot, mike.

btw, if i select each wire tube one by one, using SHIFT plus RMB, no error would comes up.

hey, sleepsheep, does this only happen with my optimized build? Or any other version?

Hmm, ok I just noticed now after mpan3’s post that you’re using an “optimized build”, i.e. a custom build of Blender. Do you have the “standard” 2.42a version too? If not that’s the one you should expect to handle this simple situation with. When I read your first post, I didn’t follow the link, I just read the “Official 2.42a”, and assumed you were using the real Official 2.42.a


I don’t think you should be using the word “official” to describe the builds on your page … until they actually are :slight_smile:

Some of the CVS builds I’ve used, if anything go to the other extreme, and warn possibly naive users that the versions are “test” versions and should be used at the user’s risk.


i just installed the *real Official 2.42a from

but the problem still there, so i guess, it is my system faults :stuck_out_tongue:
btw, no worry mpan3 :slight_smile: and thanks for providing us blender that using p4 SSE instructions :stuck_out_tongue:

ok, fixed. “Official” removed.

Hmm. Did you install the “official 2.42a” into a different directory than the optimized build?

FWIW, I have also tried mpan3’s builds, though not the one you were running, as I don’t have an SSE processor, and your file still doesn’t crash on my system.


I apologize for the tone of my previous message, I edited it to hopefully present a more friendly message.

SleepSleep’s problem may have nothing to do with your build, but I think you can see where the danger is with the word “official” when a new user comes looking for an “Official” download :slight_smile:

I have nothing against CVS builds / optimized etc builds, … I have about 6 on my system. As long as the user knows what version they’re using, it will help the debugging process for both the releases and the test builds.


i actually encountered several auto exists while using blender (luckily there is auto save and i Ctrl + W always)

but i am using onboard vga, so i can’t blame but mysefl.
it is VIA/S3G UniChrome IGP

i guess this onboard card is the culprit, i could be wrong but ftm, i just blame it, :wink: :smiley: :smiley: :smiley: