Blender FBX Exporter Armature Issue


I’m having an issue when trying to export FBX from [Blender 2.76] to [Unity 5.3.0]

Currently trying to export FBXs of one rigged model of a spider, to optimize memory and workflow I was meant to export each “action” as a separated FBX file that contains one animation. So I have 1 Mesh file for the spider and 1 FBX for each animation.

I got to use the FBX 6.1 ASCII for this matter since Unity will not “unite” an FBX Mesh with an Animation using the FBX 7.4 Binary exporter, I read at the update log that Unity developers are still correcting some issues with the FBX 7.4 Binary importer, including the way it handles spitted FBX files such as mines.

So the problem comes when I’m trying to export the most recent changes made to some animations. When exporting to Unity the animation is not shown in the preview.
I’m not sure what is causing this problem, but once imported to Unity what can see is that all other files contains the Armature object named “Armature_SB” and this new animations get exported with an“Armature_SB_0” or “Armature_SB_01” or so.

The armature in the .blend stills named “Armature” So I’m not sure what is causing the exporter to add to the name name the suffix “_01, _02”

Don’t know if this error I’m getting at the log had to do with this problem, by sure is about the FBX exporter.
Traceback (most recent call last):

File “C:\Program Files\Blender Foundation\Blender\2.76\scripts\addons\”, line 586, in execute
return, context, **keywords)
File “C:\Program Files\Blender Foundation\Blender\2.76\scripts\addons\io_scene_fbx\”, line 2851, in save
return save_single(operator, context.scene, filepath, **kwargs_mod)
File “C:\Program Files\Blender Foundation\Blender\2.76\scripts\addons\io_scene_fbx\”, line 2725, in save_single
my_arm.blenObject.animation_data.action = my_arm.blenAction
AttributeError: bpy_struct: attribute “action” from “AnimData” is read-only
location: :-1

What I get after exporting is fine, the animation is shown at “Default Take” running at the armature, I’m able to see it through FBX viewer from Autodesk.

Is there anyone there that had an idea or got the same situation when exporting to FBX? Is there any other workaround or an alternative FBX exporter I can use? Is there a way or a program to change the armature name once exported? I tried with FBX converter from Autodesk but it no success.

I have a similar issue with the same error message. I’ll go through what I was working on before getting this.

I was working on an action and was using a video as a reference. I thought I could get fancy and use tracking to guide the bones, but it didn’t turn out too well so I just made keyframes by hand. (might not be the problem but different than what I normally do)

I may have added more non deforming bones during the animation.

The prime suspect seems to be a broken nla strip. The “Rig” object has the “Walk” animation listed under in green. It’s not movable strip, and not the current animation being edited. I know of the tweak modes when pressing tab which doesn’t do anything special to this. The panel you push n by default to see just has one dropdown for “Animation Data” where it also shows the walk animation and all it’s users I can’t find.

Some bugs that occur regarding the strip

-When I unlink the walk action it will add a new user.

-users will not show up in the outliner.

-No option to push down or stash into the nla.

-can’t export with binary or ascii with the armature.

I have the same problem but and google it and got here, in my case I had renamed an Action and there was an action assigned to the mesh with this name and there were an action with the same name assigned to the armature. It has to be assigned to just one, even though I think it should always be assigned to the armature. On the outliner you can unlink the actions, it solved my problem. I hope this can be usefull to you.