Blender Fbx is not exporting multple materials??

Hey guys! I’m a blender(version 2.71, fbx exporter version 7.4) user and now learning udk. I was just playing around, I exported a uv-unwarped cube with multiple materials applied on differnet faces from blender to udk. But the problem is when I import the mesh into udk (2014 - february build) and open the static mesh editor. There is slot for only one slot for adding a material I tried several settings both on blender and udk, and exported the mesh different times but no results I searched the internet but found nothing revalent. I don’t know why this is happening, i guess i’m doing it the wrong way. Please tell me a fix for this problem, and explain what i was doing wrong.

Multiple materials in blender:

The only slot for applying materials in udk:

EDIT: When is used the older version (v6.1 ASCII) of fbx exporter, it worked flawlessly :smiley:

I think theres a Bug in the 7.4 script. Anyone knows how to fix this and how can i reprort the bug?

Anyone ?? Please :frowning:

Just use the ASCiI version then, you can choose which type you want when you export from Blender.

I just exported a binary FBX cube with multiple materials to the desktop and then back into Blender and it worked fine. So you might want to complain on the Unity forum. The bug is probably in their import software.

Press the ‘Report a Bug’ button ?

Anecdotal confirmation with Blender -> UnrealEngine4, only importing a single material channel.