Blender Fluid simulation broken? Chunky and square fluid parts.

http://http://bioillustration.de/fluidsim.jpgHi Guys
I am having big troubles with the fluid simulation for quite a while now. It produces very chunky results. In January I let a simple drop fall to the floor and it splashed nicely. When I tried to finish the problem later nothing looked right anymore, the fluid drops were sort of square. If I increase the resolution the fluid forms an X and the drops on the floor are still square. It doesn’t look realistic at all. With a resolution of 256 it looks a little better but one drop almost floods my domain. I tried 5 Version of Blender in Win and Linux, always the same result. What really baffled me was: in 2.49 now the same thing happens! Recursively the fluid simulation is messed up. Any ideas about that?
Summary:
Fluid simulation produces chunky and square results.

http://http://bioillustration.de/fluidsim.jpghttp://http://bioillustration.de/fluidsim.jpghttp://http://bioillustration.de/fluidsim.jpgHere is a screenshot: http://bioillustration.de/fluidsim.jpg for some reason adding an image by pressing the image button didn’t do anything.

the resolution is how many chunks the domain is cut up into… if you are wanting finer results… increase this resolution or decrease the size of the domain

Thank you, but that is something I have tried in all variations. As I said, it used to work fine in January. Same settings look aweful now. Even in 2.49. I tried res 256, still horrible
If I increase particles or subdivision, a lot of small drops emerge, but the main part of the fluid still looks like a blob.

Could somebody do me the favor of just adding a cube domain, an icosphere scaled down as fluid and press bake. I tested on 3 machines, 2 OSs, 5 Versions of Blender, can’t be that I’m the only one, who this happens to.

I just tried it, it works nicely on my system.

Check if all objects have scale 1.

Your screenshot looks correct for a resolution of 128.
The fluid sphere is so small compared to domain that edges of simulation are too big to make curves where you want.

A simulation at 256 in 2.63 with a correct smooth shading should give a good fluid impression.
(resolution in 2.5 and 2.6 give a better result at a lower rate than in 2.49)

But the shape of the fluid is the result of fluid world settings. You have to reduce Compressibility and Real World Size by default; if you want to give to it a drop shape during its fall.
You should also use an icosphere with higher subdivision to be a more round start for fluid simulation.

But the faster solution is to scale up your sphere or to add a smooth modifier to domain.

Pretty strong headline :wink:

Please try to uncheck the “Remove air bubbles” option in “fluid boundary” panel.

@Genscher, I tried that, no difference
@zeauro Thank you very much for the detailled explaination, I tried 256 res as well, but the result was still a quadratic blob. I managed to make it look realistic, I used tracer particles and a subdivision of 2. It’s just very weird that I have no idea what I did differently in January and the blocks and the x looked very weird.
I also had a test with a much bigger fluid mass, same chunkyness.
Well works for my project now I will try out zeauro’s suggestions if I need the sim again.
Thanks guys

Moved from “General Forums > Blender and CG Discussions” to “Support > Particles and Simulations”