Blender freezes on startup

It starts with a grey screen. No matter what I press, nothing happens. But if you switch to another window and click down while that other window has focus, it registers the click, but doesn’t show it until it loses focus then you set focus to Blender again. Resizing the window also causes it to refresh the display.

I tried putting opengl32.dll in the directory, and it “works” but is going very slow. But it does at least let me in, so that I could make any changes to settings or anything like that. I tried disabling the audio, because I read something indicating that can cause problems. That had no effect, and I cannot find or think of any other settings to try. I am fairly new to Blender.

I also tried downloading the newest version (2.79b), and the portable version. They both do the same exact thing as the other. I also tried adding -noaudio -noglsl -nojoystick to the shortcut path. I also tried opening it from a command prompt. I tried running as Administrator. I changed permissions of the program file to allow all. I installed the Microsoft C++ Redistributable. I temporarily disabled my antivirus. I also tried reinstalling Blender. I also tried restarting the computer. None of those helped either. I have been searching the internet for days, and trying almost everything, with no success.

The computer is brand new (about a week old) so I’m sure the drivers are all up to date. But I downloaded and ran the Intel Driver Support Assistant anyway, for good measure, and it said that my computer is up to date. Version 2.79 was doing fine on my old computer (Windows 7), which was many years old, so I don’t see why it would be a problem on a brand new one (that I can think of).

The computer is manufactured by Dell, the processor is Intel® Core™ i3-7100U CPU @ 2.40GHz, Windows 10 Home, 64-bit, RAM: 8.00 GB (7.87 GB usable), and it has a touchscreen (if that is important; my last one did not have that). It says “Touch support with 10 touch points”. The graphics is Intel® HD Graphics 620.

I appreciate any help with this. I hope I provided enough information. (If not, just ask.) I was thinking it possibly has something to do with the graphics driver (based on some things I came across), but I do not know that for a fact, nor what to do about it (if that is what it is) since my drivers are all up to date. So I don’t know. I am kind of hoping that one of you do, and I appreciate your help with this. Thank you in advance.

help with debugging

Could it be your protection prohibiting use of an alien software? Running as administrator and all that crap?

Did you ran Blender before or is this the first time?

If you have a chance, borrow a GPU card (Radeon, NVidia) to perform test with…

1 Like

Thank you. I ran Blender with debug by typing: C:\Program Files\Blender Foundation\Blender\blender.exe --debug

This is what was in the window after I closed Blender:

Switching to fully guarded memory allocator.
Blender 2.79 (sub 0)
Build: Thu 03/22/2018 09:59 AM Windows
argv[0] = C:\Program Files\Blender Foundation\Blender\blender.exe
argv[1] = --debug
read file C:\Program Files\Blender Foundation\Blender\2.79\config\userpref.blend
  Version 279 sub 0 date 2018-03-22 14:10 hash f4dc9f9d68b
Read prefs: C:\Program Files\Blender Foundation\Blender\2.79\config\userpref.blend
read file
  Version 272 sub 2 date unknown hash unknown

found bundled python: C:\Program Files\Blender Foundation\Blender\2.79\python

Blender quit
Press any key to exit . . .

Does any of that help?

Probably not, because I have a long list of other software on and running. Including Audacity, IrfanView, NotepadPlus, JazzMIDI (a very old MIDI sequencer), some game programs, and even a few graphics programs such as Cool-3D which is a 3D image creator although pretty old (circa 2002), it still runs fine (most 32-bit programs do), so I still use those programs. But when it comes to the open-source software (such as Blender and most of those I listed), I usually download the latest version if I get a new computer.

But all of those are running fine. Including media players. I use VLC Media Player (the latest version) and it runs perfectly. Zip utilities… everything. Out of all of the software (old and new) I am running, only Blender is having this problem. So I do not think it is anything like that. Unless there’s something that Blender would do differently than the others?

And I set Blender’s folder permissions to allow everything from every source. (I accidentally said “program file” earlier and couldn’t find a way to edit it.) And I temporarily disabled the virus scanner.

And it does run, it’s just that it does not respond. But if you switch to another window (or resize Blender’s window) it refreshes the display, and shows what it would be expected to show, for that second. Then it is “frozen” again.

So, if you click inside Blender (it appears to do nothing), then you resize (or go to another window), the circle shows up in that place where it should have been already. But it does not change it until after you have done that.

Not on this (new) computer. I had it running on my other computer that recently crashed. That computer was about 5 or 6 years old, it had no problems. But no, I have not successfully run it on this computer. It has done this since I installed it on this one.

You mean like a card (hardware)? That might be a problem, for a bunch of reasons.

Is any way I can do it without needing actual hardware? I am not very good with replacing cards and that sort of thing. And my budget at the moment is not in good shape. And I really don’t have anywhere to barrow such equipment from.

And I am almost positive that the graphics card on my (brand new) computer is more than adequate. Considering that it ran fine on my other computer which was cheap, low-end and out of date.

Maybe it needs me to change some kind of settings, or something like that? Again, it “runs” (although very slowly) when I put that opengl32.dll into the directory, so I can get in to change any kind of settings, if that would help.