Blender freezes

I hope this is the right place but…

I have a problem with Blender freezing on me. It seems to only happen when I go into Edit mode and try to border select. I’m on a vista with an Intel graphics driver. From what I’ve read on Blender’s website, Blender has a problem displaying menus and not showing the rectangle when border selecting with Intel graphics. So is it just Intel? Menus cut through the workspace revealing the graphic that displays the Blender version and rectangles do indeed not show when border selecting. I’ve tried reinstalling but it’s no help. Is there a solution for this?

EDIT: I think I’ve fixed the problem with Blender freezing. All I did was right click and Run as Administrator… Anyway it seems to be running fine now but menus still cut through the background.

PROBLEM SOLVED: I’ve fixed it mah self. I adjusted Windows visual effects for best performance. After this I found out I don’t have to run Blender as administrator anymore. Border selecting draws its rectangle and menus don’t cut no more.

See if there are any updated graphic card drivers from your vendor otherwise with blender 2.49 you may be stuck with it. Try the blender 2.5beta as you may have more luck with that.

Well, I downloaded the beta. I know I have to adjust to a slightly different interface but right now there’s not much of an interface… The toolbars are blank as well as much of the left and right panels and the… timeline at the bottom. There are many RNA errors and searches for unknown operators in the command prompt dialog box.

Ok. I’m getting getting a similar problem in Anim8or now. Border selecting draws rectangles into the workspace and every time I select a different tool in the toolbox they all disappear and reload from bottom to top. I know it’s not a Blender problem but I’m sure it’s related. I never used to have this problem with Anim8or though, so I think it can be fixed.