Blender fullscreen FPS drop + fix


(- Click for resources) #1

Hello,

I have this issue for over a year now, that i cannot play a game in blender game engine in fullscreen mode. The fps drops after a few seconds down to 12 and i had no clue why, it even did this with a completely empty scene.

Well not anymore! The solution is to disable the ‘use frame rate’ in the render panel under system.
I’m so happy that i found the solution to my problem after all those time. (//edit: better to turn of vsync instead (located next to that option))

Here is the problem/fps drop in action.

Now the question will be: How good/bad is it to disable that setting?


(Daedalus_MDW) #2

ive known about this for years, it might be due to what ever keeps track of how many sub steps it needs to do extra that gets out of sync. since the vsync is never perfect 60.

you can turn off the setting, but then time lag occurs at fps below target. its ok if you know 100 percent vsync is always achievable. and that is not easy to do.

EDIT:
i think a solution would be no vsync and let use framerate cap fps. havent tested this much, not sure if there are side effects.

only recently ive needed to start using this setting as my maps are getting bigger. suspending the scene and resuming sometimes fixes it for a while.


(- Click for resources) #3

Really why not told me before lol, i remember having another topic floating around where i asked for a solution to the fps drop, back in the day i could simply fix it by alt tabbing out of it, but that does not seem to work anymore for any reason.

only then? Hmm i even have it with an empty scene as you can see in the video xD

when i get back home i will test some more things out, only thing is that drop is very painful/annoying

Also when i use my driver recording software, the drop does not occur that much, services and gpu latency going nuts when it should drop but it will restore back to 60 in a split second

Oh and this issue is also present when exporting game to .exe


(- Click for resources) #4

Ok, i just tested this, You are right you can keep ‘use framerate’ and disable vsync, the drop is gone as well, butter-smooth now. Still needs some more testing but for now it looks promising.

Well took me ages to find a solution and now there are 2 haha, it’s so smooth now looks like a completely new blender. It will cap it a bit lower then 60 fps at 59-59.5 fps.


(Daedalus_MDW) #5

i did try telling people but they told me shut up and deal.

what i meant was my maps are getting so big, or gpu intense, it couldnt keep vsync so i had to turn on use framerate to avoid time distortion. otherwise i try not to use it.


(- Click for resources) #6

Ah ok i missed it then i guess.

Ok yeah that’s one reason to use it haha. I tried some more things out seems that if you leave vsync off everything works fine. So i’ll keep ‘using frame rate’ on and v sync off. still no clue what that vsync actually does, it ain’t real vsync else it would cap it at 75 for me and it doesn’t, stil caps at 59/60.

Anyway if someone search for it they will find a solution now.


(Daedalus_MDW) #7

vsync locks the frame generation to the monitor frame generation so they both update at the same time to prevent tearing. tearing is when the monitor fetches a new frame while the game is sending one.

to get your 75 (and see alot more tearing), set the physics tick rate to 75. be warned, this will cause the game to speed up.

EDIT:
your monitor may be 75, but you also need to set the refresh rate in the render properties.


(- Click for resources) #8

Yes i know that, and we don’t want it to speed up the engine, tried that one before didn’t go so well also i use freesync so no matter what i will not get tearing. but just that option alone 60 fps+ vsync has no use at all, due to standard monitors are 60Hz so turning on vsync won’t help in that case.

And for the game itself/for other player just include the option to turn it off and on. so anyone can have what they like.


(Daedalus_MDW) #9

oh, ok. free sync. well, thats not terribly popular, might want to test without it on sometimes.


(- Click for resources) #10

not popular, uh, it’s the thing to have, freesync/gsync. if people don’t have it(build into the monitor) they can use v sync as an alternative.

Anyway setting the refresh rate does nothing for me, untill i uncheck ‘use frame rate’ lol then everything speeds up and outputting over 1000fps