Blender Game Engine Rendering Problem

I am working on a game and this happened.
I have a Cube with an array modifier.
When i view my level in the viewport it looks ok but when i press “p” it looks like the Normals are inverted(which is not the case).

Does someone know what the problem could be?

Left: Viewport
Right: Blender Game Engine Render (when i press p)

It would be better if you gave an example, so it’s easy to find a problem …

ctrl+n recalculate normals. your face normals is wrong.

apply scale. try applying the modifier.

as stated the normals are inverted. You should also not use any modifiers…apply the array modifier first…if that does not fix the issue do the following.

  1. in edit mode select all the faces.

  2. press ‘w’

  3. select ‘flip normals’

  4. exit edit mode and press ‘P’ to play and see what you get.

He stated that normals are not inverted.
So it’s either the applying scale case mentioned above, or…
See if you have transparency checkbox checked in material. It could be sorting it wrong. Try disabling it if it’s enabled and see if it changes.

Indeed, try inverting the normals. Even though they might seem correct in viewport, in game sometimes they act weird. It happened to me as well.

Answered on stackexchange - alpha sort was used which caused sorting problems.

So my solution of disabling transparency checkbox would have worked whatsoever :smiley:

@Monster: Ah yes, I overlooked that possibility…good catch if you were the one who caught it :slight_smile: