Blender Game Engine-Simple Character Part 03

At 15:40 in the video tutorial David Ward (thumbs up) explaines how to make the character pick up a gun,in my case its a hat.

At 18:00 he parents the gun to the hand-bone. The gun follows nicely the characters movement in playmode but if I parent my snowman’s hat to the snowmans head-bone it only follows the head-bones movement but not the actual movement of the character. In other words, the hat follows the animation of the character while he is in the animated rest-postition cycle, so the hat follows the head-bones rotation and location but when I press the up arrow key to make the character move foreward the hat stays on the same spot still moving like the headbone but not following the characters walking position.

Do you know the answer to this?
Thank you for your help.

Point 1 - The tutorials forums is for COMPLETED tutorials only. This is not one of those so why post it there.
Point 2 - Please don’t post the same post 4 times. Read point 3 in the FAQ at the top of the forum

Thread moved to Game Engine Support

my apologies for posting 4 times. I could not find my post anywhere, not even under my profiles last posts so it seemed to me that the post was never posted. I do encounter some log in issues here at times and maybe it has something to do with that.

Also my apologies for posting in tutorial forums Richard but is there not a section in tutorial forums where people can debate and discuss problems they are having by following some of the tutorials?

I now added the constraint Child Of but the hat still remains at the same spot not following the head and still rocking for and backward like the head movement when the character is walking.

How come the child (hat) does the heads movement but don’t follow the parent position when walking in play mode?

Here is the game file so you can see for your self, also I noticed that some textures have not been exported it should still be enough to see what the problem with the hat is.

Thank you all :slight_smile:

Hi fybs,

I would like to help, but I think you still need to attach the blend file…

Here is the game.exe for the snowman:

I noticed that the exe file alone did not work for you to see so this is the fixed link to my dropbox folder containing the projects files. Hope it works this time and hopefully somebody can help me with the issue I am having with the snowman’s hat.

Thank you all :slight_smile:

I tried to add an object constraint as you see on the image but the hat still remains in his orignal position animating the rocking movement of the head when the snowman is walking in game mode.

Do you have a movement cube? something that the rig is parented to?

create an empty, set cursor to the head bone, set empty to cursor, parent the empty to the head bone, put the hat on layer 2. On the empty add an always sensor – and – edit object (spawn in the hat object). On the hat, add an always sensor – and – parent (parent to the head bone empty)

thank you ever so much for your feedback Thatimster, I have tried your recepie on the hat following your procedure but unfortunately it still remains the same. So I now attach the file to see for your self.
I tried it on the hat and changed it back again after the changes never affected it but I created a new button, a button like you have on your shirt, a black one and I applied your recepie on it just in case there is a conflict on the hat.
This is so strange, almost like the twilight zone.

Have a look:

The link doesn’t work, can you just click ‘go advanced’ (beside post quick reply) and attach the file to a post, would make it a lot easier to help.

Otherwise you can PM me a direct link if you prefer.

I managed to minimize the project file down to 14.447 KB but after reaching 100% upload it does not appear inside the upload manager so I will have to find out a different way to make it accesable.

hope this link works and thank’s again for your help.

thank you Thatimster for fixing and showing me how to solve the snowman’s hat (child object follow parent in play mode) issue.

I used your example on my bigger file and it works xD

In scene 1 the smowman with the hat, buttons and scarf switched invisible has to push one of the christmas boxes to the christmas tree which then switches to scene 2 where the buttons come visible.

In scene 2 the snowman has to push another christmas box to the christmas tree which then switches to scene 3 where the scarf should become visible. So in scene 3 he should have his buttons and scarf visible and in 4 the hat should become visible too. I may change the order, not sure yet but the important thing is that I can change, add and manipulate the objects in each scene seperately and here is where I am encountering my next issue.

The hat is in its place behaving how it should sitting on the snowman’s head following the heads animation and play mode position. Only where is my snowman in playmode?

I used the same settings as in scene 1 but the snowman’s mesh becomes invisible in scene 2. If I render the scene the snowman is there but not in the game mode as you can see on this image here.

And here is the link to the blender file: snowman_game33.blend (4.3 MB)