Blender, GTX960, and Linux Mint


(I also posted this on the Mint forum)

I installed and am using Linux for the first time today, so please go easy on me =)

I was able to get my graphics card drivers installed (geforce gtx 960). Here’s what appears in the driver manager:

nvidia-346 (checked)

however at the top it also says" This device is using an alternate driver"
and at the bottom is says “No proprietary drivers are in use”.

Also if I open “NVIDIA X Server Settings” it shows: NVIDIA 346.47

My problem is that the GPU is not appearing as an option for me in Blender.

I tried blacklisting nouveau as that is what appears to be recommended everywhere (I followed the instructions here viewtopic.php?f=59&t=188008&p=976009&hilit=blacklist+nouveau#p976009) but that didn’t appear to do anything.

Any help would be appreciated. Please remember I am 1 day old to Linux =P

Linux Mint 17.1 Rebecca

Solution found thanks to roblm on the Mint forum =D

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get upgrade

Nvidia X Server Settings - X Server

sudo apt-get remove --purge xserver-xorg-video-nouveau

Install cuda 7.0.deb
Synaptic install cuda7.0

Hi thanks for posting these Linux mint tips it helped with my video card setup :smiley: