Blender has very laggy (slow) interface

The interface is very laggy. When I click anywhere it takes about 0.5 to 1 second to show the menu or do the necessary action.

Now, I have Core 2 due (2.33 GHz) and 3 GB of RAM. Graphics card is intel 384 MB.

When I delete the Opengl32.dll file, the interface of blender works smoothly but I face some issues while rendering.

When I keep the Opengl32.dll file, rendering is good but the interface is very slow.

Is there any code or plug-in that I can use so that blender uses the Opengl32.dll file or the graphics card while rendering only. Otherwise, it should use the normal RAM and CPU for loading and running the interface and the modeling mode.

How can I do this?

Did you try using an older version of Blender?
Quite frankly, your hardware is horribly outdated in every possible regard and you can’t really expect current software to run flawlessly on 10+ year old hardware…

Not sure what issues you see when rendering (Blender Internal? OpenGL rendering?): Care to elaborate?

You could also try to use a lightweight Linux OS and see if that performs better.
BTW, I assume the graphics drivers are up to date?

Thank you so much for your reply,

Did you try using an older version of Blender?
I’m already using Version 2.76b and it runs smoothly on my PC without the file (Opengl32.dll).

The issue with render is that I have an incomplete image. Only a small part of the image is rendered. For video sequence editor, the image appears as white (blank). The solution to this is to add the (Opengl32.dll) file but this insanely slows down my interface.

I just need to tell Blender to use this file (Opengl32.dll) for rendering only (Not for running the interface).

I think I can tell blender to do it using python code or a plug-in or whatever the method is.

try different opengl select methods in the user preferences->system. disabling multi sample should boost performance too.

i use:

  • Opengl Select (slower but more accurate than occ-que)
  • Anisotropic OFF
  • Triple Buffer Draw (try full, but i think thats really slow)
  • No Multisample

if you have a VBO option, try disabling. intel cards are limited in vram, and this keeps the scene in vram for faster drawing.

EDIT:
im pretty sure the opengl dll thing tells blender to run opengl on the CPU and not the GPU. its called software render. very slow.