Blender in Ubuntu 9.04

Hi all,

I was wondering if anyone has got ubuntu 9.04, and has blender on it, I am having a problem with it. when I start blender, not everything shows.

heres a screenshot.
http://farm4.static.flickr.com/3345/3516945545_aee5095b29.jpg?v=0

Sorry I can’t offer a solution, but just so you know you’re not alone, I have the exact same problem.

I’d first like to know what your video hardware would be?
I have a feeling this might have something to-do with Video drivers.
Either that, or turn off the desktop effects.

try running it in windowed mode rather than full screen, you can still resize it to full screen you’ll just have the blender titlebar at the top and the little -, two squares, and x buttons. you’ll also have your bottom menu bar. you wont lose nearly as much of the screen as you are loseing now, and what you do lose will be at the top and bottom screen edges out of the way.

I guess you are talking about 9.04 not 4.09.
Almost the exact same Problem occurs on my notebook with intel x3100 graphics, while my workstation and the render-Server with ATI-Cards work like a charm.

There is a Problem with Intel graphics drivers an the new kernel. They dont seem to be working correctly at the moment. Here’s information about those problems
And here is more
If you have a different graphics card forget what i just wrote :wink:
But as the others said before it most probably has to do something with your graphics drivers

I haven’t solved the problem myself (on this computer), but here’s a little info that might help more knowledgeable people to pinpoint the cause.

When I first installed Ubuntu on this (Intel graphics) machine, Blender worked fine - but the flashy desktop effects didn’t. I followed a set of instructions on how to enable desktop effects (by changing the graphics driver), and I got my wobbly windows etc., but that seems to mark the point where Blender stopped working.

On my other Ubuntu machines (non-Intel cards) 9.04 hasn’t been a problem at all (even when desktop effects are enabled.)

well there you are!

Intel + pointless wobbly effects == broken blender:mad:
Intel - pointless wobbly effects == production ready blender:D

I guess you have to choose what you want most then, pointless fx or working blender!

The visual effects do nothing but waste valuable resources anyway. just shut them off :wink:

I have tried disabling effects, but it does nothing.

I have a Pentium D with a Nvidia quadroFX 3450 and Ubuntu 9.04… It works very good with or without visual effects and in window head or full screen mode… wished that the USB Internet modem worked that good :slight_smile:

Do you have the compiz configuration system installed?

After installing it I had to disable, in the correction (look for a bandage icon in the utility panel), the “full screen legacy support”
P.S. sorry if eventually these aren’t the exact names, I’m using the Portuguese version.

I am using Ubuntu 9.04 too and still can’t fix the problem. I haven’t known of any solution yet. I love the new version, but maybe I will have to stay with the older one until this is solved.

I have the same problem as well 9.04… I went back to Ubuntu 8.10 and everything is alright…
I have an ATI Radeon 9200 Pro card… maybe that’s why!

Ubuntu 9.04 32-bit with ATI X700 chipset and standard driver works fine here in both fullscreen and windowed mode with “Visual Effects” set to “None” – there are display problems when “Visual Effects” are set to “Normal” or “Extra”. Same hardware with Ubuntu 8.10 acts the same.

I have ATI X700 and all I get wrong under Jaunty is default cube or any other mesh. They turn half white.

Hi, same problem here with Jaunty, ATI and open radeon.
To solve (or perhaps avoid :rolleyes:) this issue you have to change your GL rendering settings, according to figure:

http://f.imagehost.org/0549/gl_errors.png

Thanks. Ill check it out.

I just registered so I get this message:

Please do not post any support questions in the 'News & Discussion' forum.
Questions need to be posted in the Support section!

So, :o anyway:

This happened to me with my Aspire One, Intel 945 graphics device, the first advice I found was reverting Intel xorg driver to 2.4 version:
https://wiki.ubuntu.com/ReinhardTartler/X/RevertingIntelDriverTo2.4
It didn’t work for me, but you can try it.

Second solution I found was to change default UXA to EXA in /etc/X11/xorg.conf, add

Option "AccelMethod" "EXA"
Option "MigrationHeuristic" "greedy"

under Device section.
It didn’t work for me. You can try it :wink:

Finally, I found this repository:
https://launchpad.net/~xorg-edgers/+archive/ppa
Try upgrading just mesa libs (didn’t work for me), I upgraded Intel driver to v2.7 too, then it worked :eyebrowlift:
I had to compile a KMS enabled kernel because desktop performance was really poor, KMS is only avaliable on 2.6.30rc kernel, so is not fully stable, but that was the only solution I found to get Blender running on Ubuntu 9.04. Remember to change EXA to UXA if you try this, xorg-edge drivers has no EXA support. I have lost hibernation and suspend also, but this should be fixed on final 2.6.30 kernel release.

PS: Sorry my poor english.

My 9.04 install runs Blender flawlessly

Mincemeat are you running a repo version of blender or from blender.org, as repos versions are notisously unstable and very buggy and strange due to bad optimisations and several changes which are not good for blender