Blender in Windowless Mode

Hey all,

I recently have been trying to get Blender working correctly on a rig with an ATI 4870 (on Ubuntu). I’ve managed to make things work by running Blender in windowless mode (blender -W in the terminal), which I prefer anyways over windowed mode.

The only problem with this is that I can’t minimize the window, so when I render something, I can’t browse the web or anything else while I wait. When I try to alt-tab out of Blender, the cursor sometimes will change, almost as if it has switched tasks, but Blender is still on top for some reason.

So basically: Is there any way to minimize Blender in windowless mode?

Thanks in advance!


There is probably a shortcut key for minimizing in your window manager. (Maybe it’s F9?).

The better way to do it is to use a different virtual desktop.

For me alt-rmb brings up the window context menu (in blender or any other app), and minimize is one of the options there.
I am using Kubuntu 8.04 with KDE 4.1.2 and compiz, so this might not apply for you.

Yeah, there is also the window context menu, which can be Alt Space, Alt RMB, or Super RMB.

I’ve tried the shortcuts and menus you’ve suggested, and they all work for normal windows, but not windowless Blender. They seem to have the same effect alt-tab does: cursor changes, Blender appears to be “unfocused,” but Blender still remains on top.

My guess is that if anything would solve this, it would be what you’ve mentioned here already. Even changing workspaces (ctrl-alt-right, ctrl-alt-left) didn’t work, and rendered Blender unresponsive until i returned to the workspace I started Blender from (blindly, of course). I don’t think there really is a solution to this “problem,” and that my best bet would be simply to not use windowless mode.

If you do have a solution, workaround, or anything else, though, please do share :D!


here’s a nice way, I guess (Gnome):
assign "shortcuts keys) to “go to desktop 1, 2, 3, 4” ( none by default) in gnome ( mine are Ctrl-F1 and so on).
Use one desktop to web, another to graphics ( Gimp?,) another to Blender…
To bring the “render window over” Blender, use F11 key.