Blender Incompatibility?

Hello all.
After googling a bit i didnt found much on the subject, so im posting my problem here.
I have two computers. One is running Windows Xp Home edition(with sp3) and other is running Windows Vista Ultimate x64 (with sp2).
To simplify everything i’l now call computer with xp computer1 and computer with vista computer2.
So on computer1 , i have Ati Radeon 9800Xt(and had driver version 9.3 installed) when it had that driver version (and without python installed) the 3 apps i tryied didnt worked (i tryied blender latest version ,milkshape latest version and Ultimate Unwrap 3D v2.15) . After installing the latest driver (9.3.1) every app started to work.
On the computer2 i have Ati eah 3870 and have the latest drivers (9.7) but even with it all the 3 applications mentioned above dont work, but 3ds max 9 works perfectly. I tried installing python (v2.4 and v2.6) both 32 bit and 64 bit versions but it didnt helped to make the blender work.
Neither did trying the blender latest version x32 nor x64.
All the aplications do start and create the main window.
But they simply crash with the next information given(for blender example, blender-2.49a-avifix-windows) :
Problem Event Name: APPCRASH
Application Name: blender.exe
Application Version:
Application Timestamp: 4a3e20b1
Fault Module Name: StackHash_fd00.
I have the latest .net framework and all the updates .
So any 1 has any workaround for thise problem ?
Thanks in advance.

i dont understand, you cant run well in any of those thre computers ? they crash

the installer may be corrupted, or mmm i dont know.

Also include which processor you have on each computer, and note you probably need the right version of Python installed for the version of Blender you are using.

If I’m not mistaken I believe the python version you need currently is 2.52 (which is not the latest python version available)

Make note of which processor you are using cause that has a big effect on which installer you use

I have only 2 computers.
But those 3 applications did not work.
The processor of the machine i cant run any of 3 applications (milkshape, blender and ultimate unwrap) is Core 2 Duo (E8500 @ 3.16GHZ). The other computer is a bit old, and has Pentium IV (@3.0GHZ).
And i think the problem is not the perl, bacause neither milkshaep nor ultimate unwrap use it . As i said, i already tried the 2 possible blender versions (x32 and x64), with python 2.6 and 2.4. I think the problem is in the grafical card, so i would test the blender on some live linux cd.
And after the drivers update on the computer1(from 9.3 to 9.3.1) it started working.
What doesnt heppen with the computer2, when i install the latest drivers (9.7).
Latest python versions are 2.6.2 and 3.0.1

This is the version of Python you want if your using 2.49 Blender

(someone correct me if I’m wrong)

Make sure you uninstall your Python before reinstalling it

Yup, it does need 2.5.2 python version.
I’ve instaled 32 bit python (writes hello world). After downloaded the .zip version (32 bit) and it gives me the same error . So i think the problem is in the drivers.
Tested on linux (Ubuntu 9.04 Desktop i386 version) it comes with the python 2.6.2, got the x32 version of blender,and it worked. (No drivers were installed).
So i think there is some problem with the drivers / grafical card, btw when i tryied to run the BackTrack 4 live cd i couldnt get into X on thise computer, while i get it to run on the other one.
So maybe the best ideia now is to write an email for ati support?
Also tried removing the driver (so it would be 8.6), it resolved another problem(Not beign to controll vga card throught epu-6 engine), but not the bleder prob =(.

Sounds like an OpenGL driver issue. ATI’s openGL drivers can be sketchy.

BTW: it doesn’t matter if your processor can handle 64 bit if the OS is 32 bit. You’re home edition computer probably has 32bit OS on it, so don’t install anything that is compiled 64bit.

So is there any solution to thise ?
Or i just need to wait for a new driver release from ati?