Blender installation

I downloaded the windows USA blender intaller from . I know DSL is fast but there is no way that you can download 4.3 MB in less than a second. Also it doesn’t do anything when you try to open it up but say it’s not a valid Win32 appilication. It says it doesn’t take any memory at all. You can’t even send it to the recycling bend because it says it’s being used by another user or program (even though it can’t be used at all) . :o I just have one thing to say about this…HELP!!!

use another mirror.

I haven’t had such a problem with Blender specificly but I have had similar problems with WinXP. Download it to another directory and preferably use a download manger.

got this once, i was behind a web cache and the file in the cache was corrupted.
other location might not be the answer. try the zip one. if this also fail. you’r screwed. like it’s a memory problem.

Turns out my computer was just on the frits. Tried it again the next afternoon and it worked like it should. Similar things have happened concerning my CD drive and when I try to save a file but it won’t approve of the name. But now there is a new problem. I also downloaded the blender converter from (under the plugin section) but it won’t open 3ds files like it says it does on the websight. I might have to start converting lightwave models. More help would be appreciated.