Blender installer, multiple versions on windows?

When I used Blender on my Mac it was easy to keep numerous older versions and betas and alphas.

I’m on windows now and I used the installer for 2.90 and 2.91.0

Double clicking a .blend file always opens 2.90 instead of 2.91. How can I fix that?

I think I remembered reading somewhere that running the Blender installer adds some other benefits (maybe .blend file preview images in Explorer… which I don’t have) but I fail to see any benefit to “installing” instead of using the portable version. Am I missing something?

I never ever use the installer, just the portable zip file, so have multiple versions on my system. I just drag N drop from explorer to Blender rather than using the windows ‘open with’. BTW, I have the same issue with my DTP package opening the older version, it’s all controlled by the default program settings, so I’d guess go into control panel and edit it there.

I did that and set it to the blender.exe of the 2.91 install folder. It still opens 2.90 when I double click a file.

on Win you have only one installed version which will open these BL files

otherwise you need to open the BL portable version and open the files

happy bl

Right click a .blend file, go to “open with” > “Choose Default Program...

A new window will appear giving you a list of some select programs as well as a “browse...” button allowing you to navigate the filesystem to a specific executable file.

Also make sure that the check-box for “Always use the selected program to open this kind of file” is checked on.

2 Likes

Yup, that’s how I did mine.

right clicked a blend file > Open with > “Choose another app” is the only option I have.
click “more apps” > click “Look for another app on this PC”
Navigate to C:\Program FIles\Blender Foundation\Blender 2.91\blender.exe

The window closes and blender 2.90 opens and loads the file I had right clicked on.

Quit Blender.

Double Click the same .blend file. 2.90 opens.

So you installed/unpacked 2.90 into a folder named 2.91 then.

This happened to me too, it’s some sort of bug in Windows. I solved it manually by using regedit in the run dialog, then fixing the registry manually. There’s really no other nice way, probably works for all recent Windows versions:

Alternatively, you can try installing the latest Blender version instead of using the portable (.zip) version.

I do this with another Windows program that I use multiple versions of.

  • Unpack or install each zip to a separate directory. (‘D:/Programs/program1’ and ‘D:/Programs/program2’)
  • Create a shortcut of each EXE to the desktop, labeling each one appropriately.
  • Not sure, however, if each Blender zip has it’s own installer and how that would affect program registration