Blender Interface and cursor messed up

Blender used to work fine on my laptop all of a sudden it got messed up just like the picture in the link below and i have been unable to fix it since then also the cursor doesn’t seem to be on point anymore. The top menu bar has disappeared even when i try to bring it back it still doesn’t work fine as my mouse cursor doesn’t click on what i place it over. When i place the cursor anywhere in the program and click, i noticed that it doesn’t click on what i place it over, instead it clicks whats on top of it. The second link explains it better as i placed the cursor on “Mirror” but it clicked on “Scale”.
The first time this happened was when i copied a blender file from my desktop to my laptop, i have since then been trying to fix it but it wont work, i have tried uninstalling and reinstalling in fact i have tried resetting my windows but still the same problem. I really need help because the laptop is what i really work on as its very fast.

Moved from “General Forums > Blender and CG Discussions” to “Support > Technical Support”

What are you using to move the mouse cursor? An actual mouse? A trackpad? A stylus?

Are you seeing mis-click behavior in other applications?

Some things to try:
Blender user preferences (ctrl+alt+U) -> system, window draw method: triple buffer. selection: one of the two instead of automatic.

The interface is drawn with opengl. Windows messing up with the gpu driver update is not unheard of, but could also be driver settings.
Could try placing a .dll in the blender folder and run blender
It runs Blender without hardware acceleration. If it works as it’s supposed to, it’s a graphics driver problem. If not, something else is going on.

Driver settings shouldn’t have any application overrides set.