Blender Interface struggling with extreme lag


#1

Blender is unable to used without a significant delay in any action (up to four seconds). There is no option to run through graphics processor. My drivers are up-to-date and my graphics card is brand new.


(SterlingRoth) #2

OS?
System specs?
What version of blender?


#3

Windows 10
/ 8gb ram (7.89 available) / gtx 1050
2.79b


(https://za.pinterest.com/GrimZAA/) #4

Is this on an empty startup?


(jaxtraw) #5

Check you haven’t got some insane levels of subsurf, bevel etc. Try turning simplify on and set everything to minimum to see if that has an effect to point you in the direction of the cause.


#6

Hi. Only way for me to fix it was to go down to the previous version of Blender.(2.78 from 2.79). Sorry for necro, just hope people can finally figure it out for future searches


(Pixelfox) #7

Did you try a newer 2.79 build? Could be something fixed since 2.79b.


(Ada Radius) #8

I was having the same problem and accidentally fixed it. Maybe only until the next Win10 update, but still. I downloaded several versions of my graphics card driver (NVidia Quadro M2000) - I had already tried the most recent and several older - and made sure that I used Win10 updating at the Control Panel, then went into properties and selected a different one from the list (properties). Like a miracle, everything is running faster now, and Blender 2.79b, after weeks of unusable lag, is fine.