Blender Internal Alpha Issue

Greetings Blender Artists,

I’ve encountered a problem with using alphas and I need help. I have done plenty of researching and testing those methods, but to no avail. What I am using is a diffuse texture, bump, and alpha image all formatted in *.png. I’ve done what I can, but they don’t seem to want to work with me. So what is this problem? It is that the plane’s shadow is being cast whereas I only want the leaf itself to be casting a shadow. Below are my settings for the material and alpha texture. Any help would be appreciated, thank you all kindly!



The wall/floor that recieve the shadow must have a material, and in that material you must enable “Recieve Transparent” in the shadow tab :
http://i.imgur.com/OBago.jpg

Seems I am still getting that problem. Even with the whole diffuse and alpha channel as one texture in one png file the plane’s shadow still shows up. I’ve also tested the following: raytrace transparencies, approximate and raytrace gathering, on/off env. lighting, AOs, texture mixture mode, all singly and combine. I would like it not to result to using BI nodes for material editing, but if that may be the other optional route I might have to.

You should post your blend, maybe someone will see what’s wrong.

These are the 3 maps I am using.​

Attachments




And this is my blend.

Attachments

Leaf3.blend (1.19 MB)

If you set your Spotlight’s shadow to Raytrace instead of buffered?

Well that definitely did it! Thanks so much for that though since it just flew right by me. If that’s the case, then would buffer shadows be able to render alphas at all then?