Blender Internal Problem , GLSL


(Walten) #1

Hello I’m modelling a Bag for Blend 4 web and im having issues with the blender internal renderer.
I hope someone can help me I didnt find a way to fix it on my own.:frowning:

I have different problems, u can find the pictures of the problems under the following link

  1. Sun Lamp only casts shadows when the object is within a Very short distance while in material mode with GLSL enabled , i have often no shadows or incorrect ones.

  2. I generated a brick texture with the cycles node, the texture appears correctly in the glsl viewport mode but is pitchblack when i use the rendered viewport or the final render, how do i correct that?

Thank you for your time


(Daedalus_MDW) #2

afaik, generated textures dont work for the glsl.

you need to increase the frustum size in the sunlamp shadow properties. set the far clip too.


(Walten) #3

thank you can you perhaps show me a screenshot of the option i dont find it on 2.79 :frowning:


(JA12) #4

Don’t mix Cycles nodes with Blender render material nodes, they use different material systems and aren’t compatible for the most part.

Switching to Blender game engine reveals more options for the lamp.

Open the console in case Blender pushes opengl errors there, I believe that’s in window menu -> system console in Windows version. On Linux and mac one would need to run Blender from the terminal.