Blender internal render freezing on this scene.

I’m working on a scene and modeled a few pills to use in a particle sim. My computer normally has no problem with rendering complex and very high poly scenes but for some reason this one kills it.

The renderer just stops working :frowning: I can go back to the 3d view but the render bar stays up top and it refuses to move past the point it hits a few seconds after starting.

Anyone mind taking a look at the file and tell me if it does the same for them or check my settings and see if there is anything you can find wrong?

I’ve tried multiple releases of blender including the newest official 2.5 release.

Even knocking off subsurf didn’t have and effect.

Droping down the number of particles has no effect until i get down to like 5 or 10 particles.

How long are you letting it think after you hit F12? I could easily be wrong, but it might be that this one is simply taking a while for it to get everything figured out. That happens sometimes when you have a complex scene, lighting and model setup with a lot of modifiers. With some things it has to “preprocess,” or calculate a lot of different factors, before it starts to render something on the screen.
But like I said, I could easily be wrong.
Try doing a render again, and just let it sit and go wash dishes or something. If nothing’s on the screen after about ten minutes, come back and send me a message.
I’m having GPU fun lately, so I’d love to do something other than mess with my own difficulties tonight! :smiley:

Oh boy!
Okay, I looked at your pills file and MAN THAT IS ONE HECK OF A LOT OF PILLS! :confused:
My computer has been crashing all night (did I mention I’m suffering through the maiden voyage of a new GPU?), but the main thing I noticed about your file is that the main pills in the group that the particles are based off of, well every one of them still has the unapplyed subserf mod still on…
I’m not sure that’s why your renders are haning like that (did the same with mine) but on the subserfs, you can’t apply them right now because View:0. Set the View:1 and you’ll be able to apply those and get them off the stack. Which might help. (The light blue pill even has a mirror mod still unapplied…) I’m not sure if that’s what’s causing the problem, or if that’s even what you want to do yet…
Other than that, it’s a tricky file that is way above my paygrade. And it would help if my machine would retain consciousness for more than five minutes a go…
Did I mention it’s Florida down here? I’m getting the fan out of the living room…
Good luck with your pills. Just don’t swallow any of those out of frustration… :blush:

I think I may have found the problem.

I thought it was causing problems before but, now I’m pretty sure that firefox is screwing with it.

After closing firefox and waiting a few minutes it unlocked and worked happily away. :mad:
It seemed to start having minor problems when they added the pluggin containers to firefox a while back.
Guess it’s time to try google chrome!

Thank you so much for your help AdamEtheredge

Okay thought I had it fixed but I guess not :frowning:

After 3 hours of rendering I’ve been stuck with this.

It refuses to go past this point.

It’s only 766,000 polys I’ve done much much higher then that with now problem.

Here’s the updated .blend if anyone doesn’t mind taking a peek.

have you tried the different rendering methods under performance>acceleration structure in the render tab? I’m not sure which to recommend, but one may work out for you. Check the other options in that panel as well. You may want to render it in layers and composite the final.

Never played around with either of those before but I’ll give it a shot and let you all know.

Thanks for the suggestions (jay)!

I think you need to re-visit your reflection materials. Really, a reflection depth of 100! I set all your reflection depths to 1 and it renders in a second. Realistically reflection depths of 1-5 are all that you need.

0.o how did that happen!

I must have hit the 0 an extra time. :frowning:

Back down to a reasonable time now! :slight_smile:

Thanks you so much for finding that, Atom!