Blender is lagging very hard when an animating with normal map on .

This is a video that demonstrates it ( I didn’t mention in the video that if i use the viewport without animation on it will work smooth and well, only when the animation is rolling and the skined mesh has normal map on it will get very laggy )

Please tell me if there is a solution to this problem . Thanks in advance .

*Edit : More info about the problem in this video :

I cannot think of any good reason to animate in textured viewport. It’s a waste of system resources.

What?.. And what if i actually wanna see how the animated character will look in the game ?..

First of all, if you are getting this much lag, your model and its textures are very likely not going to work well in a game. Your textures may be too large, or your mesh too dense, or a combination of the two. A game-optimized model should work just fine for posing with textures displayed. Second, that doesn’t matter because it’s still a waste of resources. If you have already tested and checked your textures do you really need to see them at all times while you are animating? You already know what the textures look like. Don’t waste computer power on displaying things that aren’t necessary. Solid view exists for a reason.

I’m using about 10 instances of this character not including the whole environment and the extra models, and it goes smooth ( Unreal Engine 4, means a lot of extra effects and post processing too ).
Why should i compromise for animating without textures when doing so is working smooth in any other program ?
If this is just the way it is i think someone needs to do something about it, i mean, blender is my main 3D package and i love it very much for a lot of reasons, but this little issue does not fit in such a good program.

And an other thing ! This shit doesn’t make any sense ! Look :

Could you tell us your system specs (CPU, RAM, GPU)?

From your last video I see that you get around 8 fps for playback with that normal map enabled…

  • while screen-recording in full HD and
  • while running Skype, Unity, Chrome, Word(?!) and a load of other apps.

Depending on your system resources, that might not be a bad performance.

How good is your computer? A 22k tri model with just a normal map shouldn’t be using over 300 MBs of memory, so something is wrong there.

As others have said, there’s no reason to even have the normal map on the character when animating, let alone including it and keeping it activated. I would also recommend you organize your scene: you have 1 character with one rig yet there are tons of groups, several lights, and nothing is properly named.

It’s no wonder something goes wrong when everything is so disorganized and you have several other software open.

Don’t worry about my computer it can handle with all of it with no problem .

8GB Ram
NVIDIA Geforece GTX680 ( I’m recording my videos using Nvidia ShadowPlay which is a special tool for nvidia cards only that process the recording on the GPU instead of the CPU and keeping the computer workflow smooth as if it was not recording at all ) link :
I run UnrealEngine4 + Blender + Maya + Unity + w/e and it works just fine.
And with all that, i ran this character’s animation in MotionBuilder and it worked flawlessly.
This issue happaned to me more then once with many different scenes and it started to get on my nerves.
This is something to do with blender no doubt about it.