Blender is slow on GTX 570

Hi! I want to ask you how to speed up blender viewports.
I’ve been using 8800 GTS for years, but then I bought GTX 570 1280 Mb. I expected a huge speed up, but nothing have changed. 550.000 faces with default material in Solid mode are so slow, that I can hardly work. 220 Mb of video memory are used, GPU is 100% loaded, but when I press [Alt]-[A], I get 4 fps playback on static model.
I have the latest drivers. Thank you for any advices!

UPD. Now I get fantastic FPS! -214748364 fps! What’s going on?:frowning: 3dsMax works OK on much more complex scenes:(

It’s the way it is. You should have read the forum more carefully about the performance issues with Fermi and OpenGL.
You can disable doublesided for your objects and be sure to have VBO activated. It’s not going to get better than that.

Thank you! I’ll try what you’ve said.

Max works in DirectX, so is not affected by Fermi’s dead-slow opengl.

Yes, right you are.

If anybody is interested, Xtreme-G drivers, based on quadro drivers, seem to work better.