Blender isn't giving me the option for GPU rendering

So,I have a GTX 650 graphics card and Blender is supposed to give me the option for using the GPU supported rendering but it is not. What should I do? I have the latest version ,but I had the same issue with the earlier versions too.

What you need is:

  • Nvidia drivers that work with
  • latest CUDA (5.0 or 5.5)
  • Compute device set in user preferences -> system
  • Render engine set to Cycles
  • Render device set to GPU in render properties

Thanks man,I didn’t have that enabled in the user preferences,everything else was good.Thanks again!

I’d liked to know how exactly you solved your GPU problem because in render preferences I have no device choice and when I go to user preferences and then system : there is no CUDA mode only CPU :(!
I’m currently using Blender 2.66 and my card is a nvidia GT 520MX and the driver 268.56 which is 2.1 cuda-able and as blender 2.66 is 1.3 cuda-able : it shoud work, shouldn’ it ? well, i’m lost so if someone could help me out please?