Blender keeps freezing

Blender just doesn’t seem to respond to some really basic commands at times. A few examples:

-the menu bar at the top of the screen won’t bring down options when I put the cursor over it;
-the space-bar doesn’t bring up its menu;
-in the materials tab, the menu which is supposed to select between materials (or create a new material) is totally inactive
-the M-key won’t bring up the layers widget to let me move the selected object

If one of these isn’t working, then none of them will be. Other aspects of the GUI seem to work fine. For example, when I hover over certain buttons, they change in shade. I can still resize the windows without a problem. Periodically, this behaviour ceases, and Blender functions normally for a while.

I can’t tell if this is a bug, or a problem with my system. I have only observed it since installing 2.40, although the same problem is now observed when I run older versions, which never used to behave as such.

Has anyone got any suggestions as to what might be the cause, or fix?


I run mac os 10.4.3 on a powerbook.

Did you recently update to 10.4.3? I am not a mac user but I understood that there was a problem with 10.4.3 and several opengl apps – not just blender.


I’ve had 10.4 since last Summer. Don’t remember when I picked up 10.4.3 specifically, but I have not been in the habit of blending lately, so the problem only just made itself known. Has anyone here encountered the same problem and found a solution?

Go to in the forum there is a thread on 2.40 and mac problems.