Blender Launcher [Standalone Software Client]

Triple Monitor in a PLP setup (Portrait, Landscape, Portrait), I’ve recently notice KDE has not so good multi-monitor support though, thinking of making the switch back to gnome or just use a window manager instead, but need to get used to it more.

Edit: Check it on the Linux Mint 20 VM and it was working fine, so might just be a KDE issue also.

Set it has a allow has executing file has program.

Linux Mint 20 looks pretty good, might even try that next perhaps.

1 Like

Blender Launcher 1.3.0 released!

Pretty minor release, mostly refactor and UI changes.

There is also some weird problem with experimental branches - they not working after downloading before relaunching program.
Will check it as soon as I have time.

Fixed

  • Minimize/show child windows with parent

New:

  • Download progress bar occupies all available space
  • Show headers for builds information
  • Show button in status bar to redirect to latest release when available
  • Hide taskbar icons for all child windows
  • Always center child windows to parent
  • Move all windows as one
5 Likes

Sadly the option of enabling it as a software doenst work :frowning: will really appreciate some help

Hi!
Please, provide more detailed information on what version you downloaded and what steps done for executing a file. Screenshots are welcome too!

Blender Launcher 1.3.1 hotfix released!

Fixed

  • Experimental branches fails to process after extracting
  • Select directory dialog windows causes crashes on some Linux distributions

P.S.
Hope everyone been notified about release with little ugly button on status bar :joy:
Will find time to implement better solution.

2 Likes

Hi, it was 1.3 version on blender mint mate 19.03, the file was downloaded extracted then right click /permissions/allow executing file as program. then i run it and nothing happens not even a error message, and no trace of something happening.

I think you should try to run it from bash, it should show some trace.
Maybe there is something missing from environment.
@Sudo_Blenux could you suggest something? It weird that on your side it working well.

Thanks for the quick response, i just switched to Linux, any hint on how can i make that Bash? thanks!

Def. gonna try this one out.

Is there a copy Add-on’s to different versions option?
Not to long ago I had a problem after installing a newer blender version and migrating add-on’s from previous version via the start-up menu. After uninstalling previous Blender version, the add-ons didn’t appear in the newer version.

I’ve been told that a solid solution for this would be copying it manually from blenders pref. folder.
So if a option could be added to copy add-ons from a selected version to a selected version that would be awesome!!

1 Like

here is the message i got after bash:
~$ ‘/home/render/Downloads/Blender Launcher’
[6861] Error loading Python lib ‘/tmp/_MEIyu2vT8/libpython3.8.so.1.0’: dlopen: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29’ not found (required by /tmp/_MEIyu2vT8/libpython3.8.so.1.0)

(google helped me understand the bash thingy.

1 Like

Thank you very much!
Now I get what is broken - the GLIBC on your OS is lower version than required by Blender Launcher.
There is three ways to go with this problem:

  1. Upgrade the GLIBC, however it is mostly impossible…
  2. Upgrade to newer OS version
  3. I will find time to manage and build Blender Launcher with lower GLIBC version

I’m having the same problem on Linux Mint - when I try to open the file, nothing happens. I’ve enabled permissions. Running Mint 19.3 Cinnamon

1 Like

Thanx for report!
@Nahotnoj, @Crikster, @Sudo_Blenux could you please provide installed version of GLIBC by using this command:

ldd --version

EDIT:

Ok, it doesn’t seem like a reasonable thing to do.
At my side I will need to use an older Linux version to build an app…
:expressionless:

1 Like

Hi! Thanks for feedback!
As far as I understand you used executable file or something like steam to install Blender. So, after uninstalling it via actual uninstaller, prefs gone.
I can’t really promise such functionality, depends on time. Blender Launcher downloads portable builds so there is no way to accidentally delete/override prefs by using it. At last, it is always a good practice to have a backup of prefs somewhere.

Man that would be extremely awesome, sadly version 20 of linux is a little problematic to install too. i spent 3 days testing linux mint 20 and its a p. i .t a. and honestly i got addicted to the launcher, which btw works flawlesly in 20 but… nvidia drivers doesnt feel the same. and breaks havoc in the configuration.

Hi, amazing work, I think this is actually one of my most used programs.
Anyway, I just got a new computer with ubuntu 20 and for some reason, the launcher doesn’t launch on startup, so I need to reopen it every time I close\open my computer.

Right now I don’t know when Linux builds will be live because everything just got badly broken since I started to mess with this GLIBC issue. It is super time consuming to support this builds, hope to get it work around next week…
Linux just hates me :roll_eyes:

Hi!
How do you added it to startup? I think the official way is this one https://help.ubuntu.com/stable/ubuntu-help/startup-applications.html.en

Well, the thing is, I used to use your older version of this app (the version manager) and I remember there was an option (within the app) to lunch it on startup.
So I thought it would work the same.
I sure I can do it in the OS itself (thnx for the link :slight_smile:).
I just thought it would work without doing anything else.