Blender Launcher [Standalone Software Client]

More information about this:

  1. Downloading stops at this point.

  1. After force restart BlenderLauncher it looks like this:

BL_bug2

Try to delete folders with name blender-windows64 from library folder.
Code still needs some polishing(

This solved the problem,
Thank You!

In the latest release 1.13.0 both zip files contain the windows launcher, can you please upload the linux 1.13.0 launcher

1 Like

~ Hi! Thanks for report!
I’m very sorry :fearful: Fixed the archive!

With my dual monitor setup the text only looks correct when the window is on one of the screens.

Hi!

Does monitores have such big difference in resolution?

Hello, I’m testing the program in linux (Manjaro). Program loads an I can navigate between different tabs without problems.
I’ve setted the folder path for the library but for example if a go to Downloads it always says
"No new Builds available"

The bottom of the screen shows the text
Ready | Last check at 22:39

The previous lines is an example, the hour updates every time that I load/restart the program.

If I manually copy a build from the Blender Website into the library that I’ve defined in Settings, the program recognizes the Blender version and I can launch it, remove it, add to favorites, etc

It seems that is not able to connect to Blender website or maybe something change in the buildbot and it is not finding new builds.

I’ve tried to run in debug mode with

gdb ./Blender\ Launcher

but nothing appears in the console.

It seems like a nice launcher but for now I have to download the versions manually.

1 Like

Hello, the same problem also happens to me but in Windows 10 and the version of Blender-Launcher is v.1.13.0. There are simply no downloads. I love the launcher, it is neat and quick to use.

Hi! There was a report about broken connection under Monjaro (I build under Ubuntu, might be the environment related issue between distros), you can try to build executable by yourself. It also might be possible that something blocks connection on the blender site.

Hi! Can’t test by myself, maybe something blocks the connection? Does this happens with previous builds?

1 Like

It started to crash in version v.1.12.0. I really don’t know if the problem could be internal because apparently no one else has happened to it, modify the firewall, deactivate the antivirus and delete the registry of blender launcher from REGEDIT. The blender Launcher configuration was reset but the downloads are still not available, the truth is that I don’t know how to do anything else or it doesn’t occur to me. Thank you very much for your response in such a short time. I think blender Launcher makes us all happier. If you come up with a solution, I will soon try it.

What’s happening here? Why are all these patch based builds showing up in the Experimental tab yet the Blender 3.0 Cycles X build from today isn’t?

finally everything works perfectly. All downloads already appear. :relaxed:

1 Like

Hi!
Are you sure that you don’t have this build in library?

1 Like

Sorry, I should have updated this. The 26 July Cycles X build appeared late that evening.

I’m having some issues, and I think it may be related to this? On windows: I’ve got addons in the AppData location, and addons in the build location. I’ve read things about them being copied over, no problem, etc.
But I’m trying to install Animation nodes, Extra nodes, and AN Blue Fox extensions. Animation nodes works, but the uninstall doesn’t. And none of the others work. I noticed that some of the paths are going to AppData, and others are headed to the Blender launcher location.
Is the solution to just manually unpack the files maybe? And would that be the only solution?
And before anyone gets all up-in-arms about reading the instructions for AN, when I say I get errors uninstalling, I mean I get errors even trying to disable it:


And you’ll notice there, 2 different paths. I’m wondering if that’s the issue?

1 Like

Hi!

It’s totally normal to have errors (as far as you are in experimental of course) in the built-in python modules and addons (shipped with Blender). Your issue probably related to python API changes because AN not officially supported in 2.93.

Well I was using AN with EN, which requires 2.93. But that’s experimental too, so you’re right.

Can i somehow run this great software on MacOS?