Blender + Mac OSX Leopard - Will it work?

Wow… I don’t have that problem. Blender definitely does not play well with spaces as I said before. I have more to add to that. If I open blender on space one and then close it, I am automatically yanked to space 2 for some reason. Odd…

But at least it runs well…

I’ll be getting Leopard in a couple of days (I hope) so I’ll see if I have the same problem with Spaces as you are reaper…

Cuby

I think I may have discovered one workaround to the problem with moving to another space when closing Blender. If I do not have any other applications open on that space when I close Blender, then am yanked to Space 2. If I do have another application open, say the terminal, then I am not yanked away when I close Blender. So, I can prevent the behavior simply by opening a terminal on that space. However, I should not have to do this because other applications do not initiate a Space jump when closing the last window.

Also, I have not found a work around for the fact that I was being yanked back to the space with blender during a long render.

On which Mac?

Hello everyone here, FYI: I am running Blender fine with Leopard on a new MacBook Pro.
However, the Yafray renderer does not seem to start up anymore. Also, the separate installer of Yafray (which I think should not be needed) failed: Could not install some files in “/”, despite having entered my password. Anyone else had these issues?

On my MacBook

I just posted a problem with Yafray on Leopard, but it is already solved: Apparently during the install the path to the sequence plugin got messed up. By setting this again to the correct location things were solved.

So: On a the newest Macbook Pro with 4 GB RAM and Leopard Blender 2.45 works fine for me, including Yafray.

Kris

is anybody working on a 64bit version of blender for Leopard?

Today I’ve got an IMac. and it’s installing Leopard right now. So I will see tomorrow if blender will work

I get crashes every time I try to bring in a quicktime file as a texture. Kaboom.

Hmm, sequencer too. Looks like Blender is no longer a video app. darn.

I will get Leopard on MacPro Octo within these next weeks.

  1. I always keep the former OS on another partition or disk each time i upgrade (avoiding any sort of incompatibility by booting the more adapted OS version)
  2. Leopard is 64 and 32 bits… so there should be no problem running any app.
    I’m looking forward my next 3d era (i’m involved in websites and cutting-compositing these days) and will also give some feedback.
    Till then, i wish a nice time to everybody around.

I’m having no problems with Blender, however, I’m having big showstoppers with Gimp. Seems completely broken in Leopard. X11 seems okay, and Inkscape seems not to have any problems, but Gimp just crashes on opening. I’ve installed several different versions and flavors of Gimp (Gimpshop, etc) and I have no luck with any of them. Anybody else have this problem?

I heard that Leopard changed X11 so that many standard X11 programs no longer work. I did not upgrade my X11 install from Tiger to Leopard… so Gimp works just fine. In fact, I got the new version of Gimp and it’s better than ever! Texturize works now on Mac! Best plugin-in ever for making repeatable textures for us in blender!

is X11 fast?
(i heart that it actually slow)

This will install psyco in “site-packages” inside you /python/bin.
No too complicated.

Psyco requires Python >= 2.2.2.

Speed was doubled afterwards for me.
In case of problems i can try to host a patched psyco-distribution soon.

I’ve done these steps and I can import psyco it seems, but now demolition.py crashes blender with a segmentation fault every time. Do you know how I can test psyco outside of the demolition.py script? It imports fine in IDLE.

I have 2GB ram on a MacBook (about a year old) and I just installed Mac OS 10.5 (Leopard) and I have the same problem as Pluuske:

i’ve installed leopard a few days ago… But blender is way to slow I can’t work with it like this… even if i add a plane it doesn’t scale, move etc. the way it used to do… now i have to wait 5 seconds before it’s scaled/moved… It’s just like when there are so many vertice that it’s getting so slow…

someone of #blenderqa said:

i saw a note about new macbook being slow with heavy opengl… maybe it is not the new chipset but the new os with integrated video

Also it would be cool if blender had a 512x512 icon for leopard, but this is minor…

Hmm, Leave my MacBook Tiger. Poor GMA 950… I guess that mini and some of iMac should have the same problem.

That’s what I found with the beta version of Leopard on a GMA chipset. This is very bad because it means that anyone with a Macbook (maybe not the new one) or Mini who updates to Leopard can’t use Blender unless they install XP using Bootcamp until the issues are resolved.

Do the same issues occur with a version of Blender built using Leopard?

If so, it must have something to do with the way Blender is using OpenGL. Other software doesn’t seem to have problems so why does Blender? Wasn’t there going to be changes made to the way Blender uses OpenGL at one point?

I’ve installed leopard on my Imac, and downloaded blender afterwards and it wordks perfect now… havent’t tried to re-download blender on my MacBook. but maybe it works. I don’t know…