Blender MDD Export Import Issue


Dear Blender Developer,

A quick question, why does Blender export MDD data in Right Hand Coordinate, but import MDD data with Left Hand Coordinate.

The result is an animation that is flipped. Only if I scale the whole scene in -Z, I am getting the correct result.

I analyze it in depth, and using other package as well:

Animation that is flipped by MDD export, is there a way to correct this?


  • J

This is a screenshot of the animation to proof it.

Could there be a switch inside MDD Export to change the Coordinate System from Left to Right or vice versa?


it will explicitly flip meshes that way on exporting, must be a compatibility thing…
but it is easy to add an option to keep objects untouched to the script

try replacing io_shape_mdd folder in addons with this one:

would be good to know the reason behind this anyway…

thanks for that alternative to the script Liero. did you just add “Export Flipped Y and Z” there? do you think you miss something, I think the script is not really working. I will check again tomorrow after sleep.

my solution was to export the animation twice. the second time around exporting using flipped animation giving the correct result.

I like this MDD thing because it really baked animation and resulting in mesh with Shapekeys that are interpolated.

this is one feature that maybe LIERO, OSCURART and ATOM can probably work together to have proper OBJ sequences exporter which then able to load it back just like MDD :slight_smile:

next in my request will be Blender Particles Points Export Import.

yep, I think unchecking that setting would export meshes correctly… but could be wrong

I tested many times, I think unchecking the box will give MDD that is static.

With the box checked, it exports the animation that is flipped.

My trick is to export it twice:

Do you think you can tweak the script so when the option box is unchecked, then it does not flip? Maybe something is missing.

Thanks a lot beforehand, Liero.

sorry enzyme, tested it quickly on a static mesh and totally forgot to add spatial transformations…
try downloading again, don’t trust myself anymore :stuck_out_tongue:

Liero, and now when I use the unchecked one, it does not mirror/flip the animation, but it is going into weird perpendicular direction :slight_smile:

Still not 100% correct.

but it seems to work here, in fact I didn’t change anything in script, just added the option to skip flipping… maybe your ‘reset’ mesh has some transformation?

Aha, that’s why… you are right, importing and exporting OBJ causes the ‘reset’ mesh to have some transformation, the MDD itself is correct. 90 degree in one axis. Zeroing all transformation and all good! :slight_smile: Cool, you fixed the flipping animation issue. I think this MDD tweak should be included in the next version of Blender. I don’t know why nobody spotted it.

Thank you Liero!

  • J

hey guys, i wanted to ask if this issue is it fixed in the current releases of blender 2.64?