Blender not loading properly (Orange branch, linux)

I finally managed to get blender compiled on my linux install (fedora core 4), and I ran into a bit of a weird problem.

I have a dual-screen set up, using the ATI provided display drivers. The display is set up as a single spanning desktop.
My problem is that blender only appears on one monitor, but it behaves as if it should be on both. It is stretched as if to cover both screens, but my second screen still displays the desktop underneath it. To make matters worse, I can’t interact with the visible part of the desktop, yet I can manipulate blender from it.
Finally, when I start blender, all the system’s menus and task bars disappear, as well as the program’s (blender’s) titlebar.

This line came up when I ran blender from the terminal
Xlib: extension “XFree86-DRI” missing on display “:0.0”
Don’t know if it has anything to do with it.

I’m just starting out with linux, so I probably just set something up wrong, but if anybody has any ideas, they would be apreciated.

Not a Blender problem:"XFree86-DRI+missing+on+display+%3A0.0"+&btnG=Google+Search


The long and short of it: the way dri is set up for your ATI card, you can only have 3D acceleration on a single head. Because of that, Blender will only properly show on your primary monitor.

As far as things disappearing… they aren’t. It’s normal behavior. Blender defaults to a full-screen borderless window. You should be able to ALT+TAB to other apps and (depending on the WM you’re using) minimize Blender.

If you start Blender from the command line, you can use the -w and/or -p options to tell Blender to open with window borders and/or at a particular size/location, respectively. Type ‘blender -h’ from your terminal window for more details.