Blender not reading Python help

I just installed PyFFi, Python 2.5.4 and Python 3.0.1 and when I open up Blender it is still saying:

Compiled with Python version 2.6.1.
‘import site’ failed; use -v for traceback
Checking for installed Python…No installed Python found.
Only built-in modules are available. Some scripts may not run.
Continuing happily.

Please help.

you need to install python 2.6. the same python your blender version got compiled with.

fixed it. Thanks man :wink: