Blender not responding after i bake a fluid stimulation


so i was following the above shown tutorial on making a water ffeature animation on my latest version of blender… i did all the part except for the part where i had to bake but i did not have the bake option on my physics properties in fluid stimulation option, as in the video so i had to go to objects>animaiton>bake action. and it would say not reponding for quite for some time and if i leave it there it bakes but nothing runs smoothly anymore. everything becomes so slow. what should i do… im running windows 10 and i also am pretty sure it is not because of the specs of my hardware… id appreciate if anyone could help me. thankyou… here is my blend file if you need to check it out and see if you have the same issue… https://we.tl/t-sEDtgRscRI

That has nothing to do with simulation baking.
Bake action is there to create transform regular animation made of drivers or curve modifiers into keyframes.
So, that is totally normal that does not solve the problem.

Default caching mode changed into master. It will not be the same in 2.83.
So, tutorial is made to be followed with official stable release 2.82a.
If you are using 2.83 Beta or 2.90 alpha, you have to change Cache Type from Replay to Modular.
This setting is into Cache panel of Domain properties.
With Modular cache type, Bake buttons should be visible.

Replay mode is there to preview result during playback. So computation is happening at each frame change.
When you bake, computations are done for all frames during baking. And then, playback can be fluent.

1 Like

thanks a lot. this solved my problem.