Blender not responding on render, nowhere near resource limit.

Hello again. (Blender 2.71)

I’m still trying to get to the bottom of this ‘Not responding’ lark. I’ve managed to get rid of the pc hanging, this must have been a problem with the GTX670 card, without that the system is completely stable. But… During a render last night of 3000 frames it got to 1127 and ‘Stopped responding’. Ironically the frames around this range are the most simple in the animation. It’s a rough cycles preview before finalizing a few things.

I re-started Blender and the animation and have been watching it for another 200 frames, the peak GPU load is less than 400m of 3gb, the CPU peaks for each frame (as you would expect) at around 80% for a fraction of a second, then settles down to below 15. System memory is never more than 4.5 of 16Gb. The Disk activity is absolutely minimal, saving a png every 15 seconds.

I’m sure this isn’t a hardware issue as I don’t have problems with any other software. The machine is used for loads of other things so there are other processes running, but nothing hogging the system at all. And it’s only Blender that stops, and only ever when rendering.

Anyone have any ideas of things to check?


Check the fan speed log of your GPU. Sounds like overheating to me. The stopped responding sounds like the nVidia mechanism that was put in place in the drivers to prevent all out machine crash. Instead the driver quits responding to prevent a machine crash thus relaying the crash to the host application instead.

Try rendering with CPU only to see if you can make it through the animation. If so, then you know it is a GPU issue.

Now, that’s interesting, it does sound like that could be the problem. With the older 670 card in the machine did completely bomb out, or freeze. With the 3x GTX780ti’s I get the non responsive app, they are crammed into a rather small space.

I will try to track down these logs.

Thanks Atom.

Also, if you are on Windows there is a free program called Afterburnerwhich allows you to draw a custom fan graph to force the fan to turn on at 100% when a specified temperature is reached. nVidia aftermarket developers are notoriously bad at implementing decent temperature sensors. I have not had a single nVidia card actually turn the fan on at the correct temperature. I use Afterburner on my system with a custom graph and my fan works as intended now.

Thanks Atom. Downloaded and installed. Fan profile setup and working a treat. The monitor is the best I’ve seen of any such software. And with the default settings I’m sure the cards are rendering faster.

Do you know how accurate the temperature sensors are on GPU’s? It seems odd that I have readings that spread 20 degrees between the three cards. Without swapping them round, which I might do if I get bored, I guess there’s no way to tell.

Anyway, brilliant. Thank you.