Blender (Not responding) on start-up v2.73 Windows 7 pro 64 bit

Blender (Not responding) when launched.

2.73 was working well, but it crashed.

When I try to restart it the window opens with the blender icon and name but a completely grey featureless window and then after a minute or so the window adds the words (not responding) later windows closes it or asks me if I want to close it.

I tried launching 2.72b and it has the same frozen result.

The odd thing is that if I double click a .blend file. It opens in 2.72b with very old user preferences and seems to work.

Nothing on the computer has been changed inbetween working properly and the above fault – just the crash of blender which came when I tried to do an animated render at 15% size. (This was the only unusal thing that I had done.)

(I then restarted windows in case that would help, but it didn’t)

It could be an issue with startup or userpref files. I would isolate Blender from those to narrow down the possible cause.

If Blender doesn’t see a config folder in its installation\2.73 folder it writes and reads userprefs here:
C:\Users\username\AppData\Roaming\Blender Foundation\Blender\2.73\config

If you create an empty folder named config in Blender’s installation\2.73 folder (the folder with datafiles, python, scripts folders) it will save and read userprefs, startup.blend, bookmarks.txt, and recent-files.txt there instead of the config folder in the OS users path. (This is a feature. You can use the ZIP downloads and run Blender from folders to have multiple “installs” each with their own preferences and bookmarks).

So either backup and empty the config folder in users path or put an empty config folder in the installation\2.73 folder and see if Blender will start clean. If so then it’s either the userpref.blend or startup.blend. Sometimes Blender doesn’t like a userprefs file handed down through earlier releases. Sometimes the culprit is an enabled addon in the startup.blend.

Hope this helps. If nothing else this step will rule out config files as the problem.


Thank you for the advice.

It is very odd that I am currently running 2.72b which ran from double clicking a .blend file, but launching that version directly from the .exe file doesn’t work. Does your comment about trying an empty config file still apply?

I looked in users etc and don’t see anything resembling Appdata.

I looked in the path and the folders for 2.73 and those for 2.72b Neither appear to have a folder called ‘config’
What they do have inside ‘scripts’ is a folder called ‘startup’ and one for ‘addons’

I did not know that the appdata folder is hidden in windows 7 (You can’t see it) Therefore I could not find it.

To find it go to the user/ folder and then type into the address the next step /appdata/

What I tried is changing the names of the startup and then the preferences .blend file.

When I changed the prefernces.blend to preferencesOLD.blend I could then launch blender properly.

So the probelm was something in the prefernmces.blend file.

What I still don’t know is why double clicking an existing project.blend file was okay, but launching belnder.exe would freeze.

Hmmm that is a mystery to me as well since userprefs aren’t saved in a project .blend. Maybe there’s something else that goes on with project, startup, and userprefs blend files that I’m not aware of.

I somehow missed post #3

I always forget about hidden windows files. Sorry about that. I unhide everything and forget about it.

About the config folder not being found in the install folder. That’s how it works. If you create an empty config folder in the folder where that scripts folder is found then Blender will see and use that one instead of the config folder in appdata. If you use the zip downloads and run Blender from folders you can have multiple “installs” which will either use the config files in appdata or their own seperate config (userprefs, startup, bookmarks, recent files list) as you please.