Blender not responding

Hi,

I have been using Blender for about a month, installed on Ubuntu. Using addons only compatible with 2.64 I downloaded the zip and extracted from blender.org. The problem now is that it is not responding. I have tried deleting the old (2.64) and do install from terminal (2.66), just to see if that one would work. What I get when running the install is ;

Reading package lists… Done
Building dependency tree
Reading state information… Done
blender is already the newest version.
The following packages were automatically installed and are no longer required:
libdc1394-22 blender-codecs-ffmpeg0.10 libgsm1
blender-openshadinglanguage-data libfaac0
Use ‘apt-get autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

And then trying to run it I get;

connect failed: No such file or directory
AL lib: pulseaudio.c:331: PulseAudio returned minreq > tlength/2; expect break up
Writing: /tmp/blender.crash.txt
Segmentation fault (core dumped)

I also tried manually clicking the Blender icon, but nothing happens. I am quite new to working from terminal and I am not sure how to sort this out. Be happy if anyone had some input.