Blender Not Running in Ubuntu...

Ok, I can get the Blender version from the add/remove progs app… That one works, but for some reason, the downloaded file form, even though I extracted it, when I double click on the blender app, nothing happens… what am I doing wrong?

I’m using Gnome

I had the same problem a few weeks ago. The Swedish Ubuntu community managed to explain something was wrong with my graphic card and advised me to try Envy. It worked for me, but be sure to read some about it before trying it. Googling on “Envy Ubuntu” returns a lot of information.

Good luck
/ Mats

EDIT: Open a terminal and try simply “Blender”. If Blender is installed your computer will probably find it and explain what is missing.

Great. I’m running a ATI, but I can run the APT_Get of blender…

Here’s the error I’m getting when typing in ./blender in the dir blender is in.

./blender: error while loading shared libraries: cannot open shared object file: No such file or directory

Solution is easy… Boot into windows :smiley:

Problem is simple…

Windows Partition died when I ran Ubuntu, this is all I have.


the error means that the program needs a library but can’t find it. The package that provides the library is called libopenal0a (for Ubuntu Gutsy at least). So for installing from the command line you would need to type:

sudo apt-get install libopenal0a

or seach for the package libopenal0a in Synaptic or AddRemove and install it from there.

Hmm… I did that, and I still get the same error. The package installed fine. there were no errors, do I need to configure it? I don’t know what’s going on, BTW your help is greatly appreciated.

According to this thread “you need to install OpenAL for your distribution”. Open Synaptic and do a search on openal. You should get a list which tells you libopenal0a really is properly installed.

Personally, to install Blender I simply used the “Add/Remove” function in the program menu and it installed nicely including all dependencies. That is what I recommend, both for Blender and other programs. (And that’s not me saying I know much about Linux.)

/ Mats

Ah, for some reason, I just felt like selecting the libalut part of the error, searched that, installed libalut0 and blender now works…

Thanks for picking my brain guys!

danizzil14, great you got it working.

If this ever happens again and you can’t figure out which package you need to install (sometimes it isn’t obvious), you can go to to section “Search the contents of packages”. Type in the name of the missing file from the error message and click search, you’ll then get a list of packages that provide that file.

Neat! Thanks for the help!