Blender not running on Linux

I just started using Linux, and am trying to install blender on it. I extracted all the files that I downloaded, then went into the new file, clicked on blender, and nothing happens. I am using Linux Kubuntu. How do I run blender on Linux?

There is linux 32 bit - Linux x86-32

and linux 64 bit - Linux x86-64

Which did you download, and is your system 32 bit or 64 ?

If you open a terminal and type sudo apt-get install blender it will do it for you, though it won’t be the latest version. has Blender 2.49b for 32 and 64 bit ubuntu 9.04 (I’m guessing you have the most recent Kubuntu ?)
There is a link near the top of the page where you can set which ubuntu version you are browsing applications for.

I am running the latest 32 bit Kubuntu, and I did download the x86-32 version. I will check those links now. thanks for the help.

If you have the correct version try right clicking on the Blender executable and choose properties -> permissions. Make sure ‘Allow executing file as programme’ is checked.

Another option is to open a Terminal(or Konsole). Change Directory to the Blender folder. If it is on the Desktop then cd Desktop/blender. Then type ./blender (dot slash blender). If there is a problem you should get some feedback in the Terminal.

There are multiple reasons why programs might not run. If you are new to Linux, it’s probably a good idea to just get someone who knows Linux to see how the program goes, and then to show you their methods and/or any troubleshooting tips as applicable to your machine / set up.

If we were to say “open a console” you would be asking “what’s a console?”, or if we said “cd into xxx directory” you’d be saying “wtf?”… somethings are so much simpler if you can just see it.

It should take them about 30 seconds.

i tried what organic said and got this error: ./blender: error while loading shared libraries: cannot open shared object file: No such file ordirectory

Well there are 2 32-bit versions, a python 2.5 and a 2.6 one, maybe you have the wrong one.

oh, I never thought of the different python versions, I’ll go try that now.

I got the correct blender-python versions and it’s working now, thanks for the help.

There needs to be a newbie wiki specific to Linux?