Blender not using GPU to render?

I have a GTX 560 Ti and I’d like to use it to render my animations. I have changed the renderer from CPU to GPU under User Preferences, but this has no effect. If I look my processor and GPU usage, my processor is about at 50 % and my GPU is jumping around 0 % and 3 %.

Is that a bug or do I need to do something else?

have you set gpu rendering in the render properties ?
Wiki entry: http://wiki.blender.org/index.php/Doc:2.6/Manual/Render/Cycles/GPU_Rendering#Configuration

Yes I have.

you have to set your gpu in your settings

File>User Preferences>System
its at the bottom left

@LordOdin OP wouldn’t be able to switch to GPU if that wasn’t set in UP at all imho.

Where did you get the Blender from? What is your OS? Have you got latest nvidia drivers for it?

Simple question first, are you rendering with Cycles or Blender Internal?