Blender not using GPU to render

Blender 2.71
Xubuntu 14.04.1
EVGA GeForce GT 640

In UserPreferences -> System -> Compute Device, I have CUDA selected, and in the dropdown menu, GeForce GT 640 is selected, so Blender obviously knows my graphics card is there, and is supposed to be using it to render.

In the Properties -> Render panel, under the Device menu, I have “GPU Compute” selected.

Even though all these settings are correct, Blender always renders on CPU. I have a very large scene and I can’t afford to sit and wait 2 days for it to render on CPU

Did you change the tile size on the performance tab? GPUs like bigger tile sizes (at least 256x256).