Blender not working correctly on MacBook Pro

First I’m new to blender.

I have done a lot of research and experimentation and just need some help.

Shadows are not showing in 3d view or in the render.

Lights seem to work but light passes through one object and onto the objects beneath without casting shadows.

Objects have materials that receive shadows, lights are casting shadows, etc I have eliminated all the advice available, I’ve updated python, and pursued everything suggested to this point.

My blender files that I create, when loaded into blender on another machine do have the correct shadows. So it has to be my video card, OS, local machine,or incompatibility of some sort.

I’ve tried 32bit and 64 bit versions of the OSX versions and the 32bit Windows version running in Parallels on my mac. Same exact results.

Even when I download other blender files that have shadows they don’t show on my machine.

I’m using:

MacBook Pro, 2.4 GHz, Intel Core Duo
4GB Ram
NVIDIA GeForce 8600M GT 256mb
OSX 10.7.3

Blender 2.62

I can provide links to the blender file. As a new user I can’t post URL’s right now.

Please help if you can.

Vidlocity Media

First thing to try is if shadows show up in the default scene. Go to the top header and under ‘File’ choose Load Factory Settings.

Then add a plane to the scene (shift+A) & place it under the cube. Then render (F12).

Are there shadows from the cube on the plane?

Yep, tried that. no shadows on plane, played with material settings, light settings, etc…

Which revision no. are you using? You can find that in the upper right corner of the splash screen. One of the latest build on Graphicall for Mac is 44639


It’s the latest one from blender.

i Downloaded r 44548 from Graphicall and same result.

OK, WOW, SOLVED. I was hitting the Render buttons in the 3d view and no shadows were rendering. When I click on the Render buttons in the render tab, Viola! Shadows. The two rendered views don’t look anything alike so that part is frustrating. but I can get over it.

I was hitting the Render buttons in the 3d view

Do you mean the opengl screenshot button in the 3dview header? That’s just a screenshot of the 3dview…

And btw, pressing F12 should work too, as I mentioned earlier