blender + nvidia = wrong framerate in animation playback?

hi there!
i’ve been animating a few clips in blender and i just can’t get blender to do the playback at the right framerate!
i’ve already tried with “sync playback with frames/sec” on and off, with the alt+a hotkey and the play timeline button and all this give me different results but none at the correct speed / framerate…

i’ve tried in different systems,
one with a nvidia 9800gt, other with a nvidia gtx 285 and an older one with an ati X700 and only the ati played at the right speed… (24 frames/sec)

im using the latest blender and graphic drivers. :eek:
is it just me…?

please help… i cant get my animation timings right like this… and doing playblasts all the time is a very slow and frustrating workflow…:no:
:spin:


edit:
video showing it here:
http://www.box.net/shared/pjqqebtdhs

1st play “alt+a” - sync off
2nd play “alt+a” - sync on
3rd play play button - sync on
4th play play button - sync off

Are they consistantly slow/ fast with the timing, or do they change from slow to fast during the animation?

If it’s the latter it could be an issue with the drivers and i would recommend going back a few releases, also try turning on vertical sync in the nvidia panel and triple buffering, see if that has any effects?

I don’t think Blender does real time playback. I have never seen any claim that it does. When I turn on Show FPS, it never shows it.

thanks for the answers, but so far no luck :
the framerate seems to to start fast and slow down, but that realy depends if i use the shortcut “alt+a” or the play button… but none plays at the right timing…

you can see it here:

http://www.box.net/shared/pjqqebtdhs
(compressed with 7zip )

1st play “alt+a” - sync off
2nd play “alt+a” - sync on
3rd play play button - sync on
4th play play button - sync off

I’ve tried vsync and triple buffering, but the results were the same :
any more ideas?..

Try it with blender 4.49 not 2.49a.
2.49a has a bug with the alt-a animation playback.

Same thing recently discussed here. Maybe some help.

http://blenderartists.org/forum/showthread.php?t=162065&highlight=animation+playback

Richard

i’ve tried 2.49 and an optimized build, but same luck…

thanks :slight_smile: i’m reading the threat rigth now, seems i’m not the only one. strange thing is that with an old ati card it worked…

The “show FPS” option is only ment for BGE. And it works :wink:

OH GAWD, you got a threat?!? And your not the only one that did?!?

Anyway, I’ve run into the same problem. I think that the more complicated the scene is, the slower it runs. I don’t think blender has ever played back at a reliable speed.

:stuck_out_tongue: sorry not native english speaker, so sorry for the mistakes :stuck_out_tongue:

:
yeah… that sucks… timeline isn’t of many use then… :\ i have to relay on playblasts… kinda breaks the workflow… :\ would be nice to have the realtime playback.

i find it strange that this issue hasn’t been addressed… as an animator i find a reliable realtime playback essential for an efficient workflow.

thanks

Ops, that used to work, way back then, when there was no time line window.
I just checked it with my good old 2.46.
There the sync option in the animation panel works, but only with ALT_A. ( skips frames as needed )
When i start from the time line window the fps seems to be ignored.
Looks someone was trying to fix the time line window making things worse.
Eeeek! SVN build plays really weird.

Agreed. Just out of interest, which apps have you used that do feature a 100% reliable realtime playback in the workspace windows? All those I’ve used (including Maya) have either employed a modified playblast setup (the app does all the pre-rendering and plays back in a special window) or is just as susceptible to slowdowns as Blender. I find the frame-dropping can be a problem, too, as it’s the flow and timing of specific event-frames that is usually of interest, which can be broken by frame-dropping.

well, i’ve used 3d max and maya, and i feel that maya playback was the more reliable… i’m not saying its perfect, but allows that i only need to use the playblast on the refining/finalizing stage… but even max allows to sync framerate to playback…

and if the rig / geometry is simple enough, then slowdowns are rare… (or using a proxy…)

the problem is that blender is to fast playing… and if i adjust my timings to that, when i render / do a playblast / import to a game editor, i get a very different (and slower) result. :confused:

Same for Blender in my experience, though there are other circumstances that can make things slow down hugely regardless of model complexity, such as using script-driven IPO channels for bones. That’s why I use the “playblast” method so much, since my “Kata/Katrice” rig is very script-dependent.

Too fast!? That’s a new one :wink: Again out of interest, where/how are you setting the FPS for your in-workspace playbacks? Since about v.2.46 I’ve used both ALT+A (most reliable IMO) and the Timeline play button with good results for non-complex subjects. Never seen it playback too fast, though.

well i’ve animated some walk cycles /run cycles for a game unaware of the playback problem, and when i imported them to editor they were way slower… while the playback in blender looked fine… but then i did a playblast… and the actual speed was slower… blender was playing it faster than it should…

i dig deeper in the problem…
here is a comparison on the left viewport playback (alt+a) captured with CamStudio (2 diferent playbacks) on the right the actual playblast.

http://www.box.net/shared/y5snc8rnfi

some frames are in sync… most don’t… :
doesnt really seams faster or slower… just with different timings… :s

No offense, but how reliable is CamStudio for capturing a reliable FPS that would correspond 1:1 with rendered “playblast” frames? I’ve used a number of frame grab and frame dump utilities and they all suffer from lack of exact sync/FPS. Not saying that Blender’s playback doesn’t appear faster, just that the CamStudio capture may not be showing it well. The lack of sync in the frames tells me that the capture may not have been very accurate (can’t fudge that in the “playblast” frames).

In terms of importing the animations into an editor, which editor? If for a game (such as Unreal’s UEd), it’s my experience that the frame rate for real-time playback in game editors and in-game (like machinima) is not all that stable. In making my Metropolis Reborn machinima demos (UT2004, UEd 3.0), I had to jump through some major hoops to get enough frame dumps to get a reasonably smooth action when making them into an .avi. Playback in-game was pretty spotty, though within what I consider a “playable” frame rate. In Maya, the figures animated beautifully, with decent (if not exact) playback rate, but in-game it was another matter altogether. Same was true of sequences used for playable in-game character models with custom animations.

yeah i know… but its the only way i’ve got besides my eyes :, and its close to what i see on screen…

i’m importing them to unity. and i have confirmed the speed with the blender playblast. it’s really (unfortunately) a blender playback issue… :\

Animation button panel. But seems to be broken in 2.49a. 2.46 works fine.Checking 2.48a still works fine.


I’m having the same playback issues. It’s not a matter of trying to get realtime playback, though.

When I press Alt-A, the playback hesitates for some fraction of a second, then it rushes through the frames to catch up to where it would normally be minus the initial delay. That’s the speeding up and slowing down effect. Also, at the loop point of the animation, it hesitates on the last frame. Repeat cycle.

I’ve never had this issue before, but I can’t remember exactly when it started. Also, no driver changes or system configuration changes have been made.

I booted Windows into Safe Mode and the problems go away, so I suspect there’s some incompatibility with the nvidia drivers. I turned down all of my driver settings and the problem persisted.

So, I started going back to previous versions of Blender and the problem went away when using the initial release of Blender 2.49.

Is there a better solution? Thanks.

EDIT:
Here’s a short video demonstrating the issue.
http://www.blendernewbies.com/tmp/anim_prob_249.2.avi

well 2.49b didn’d solve it :frowning: neither newer graphic drivers =\ guess that invalidates animating on blender… :frowning: sniff