Blender Octane Plugin - Freezes on Render Viewport, same issue with new PC

Hey Everybody :slight_smile:

I’ve been having an issue with the Octane Blender plugin for several months. It was working just fine, then it started freezing when I enter the Rendered mode in the viewport. It displays the message “Waiting for image…” and it just hangs there, nothing happening. If I leave it for 5 minutes, it might move on to “Render-target evaluation on server” and update the image, but it takes minutes for each minor refresh and it’s completely unusable. This issue happens no matter what the scene is. I can just have a cube and go to the render viewport and it will freeze. Or I could have a scene full of geometry, it really doesn’t make a difference. It seems like it’s working, just incredibly slowly and each step taking far longer than it should. If I open the Octane Viewport from the menu, after waiting for 10 minutes or so for a cube to load in the Blender viewport, the Octane viewport will display the scene correctly and update as normal. The Blender viewport will still be frozen. If I try to do an F12 render - it will be the same. Waiting for image will display and each next step will take a very, very long time.

I’ve tried updating to the past few versions of the plugin - it happened with all of them. Currently running the latest version, latest Prime as well - no change. Latest NVIDIA drivers, just did a clean install of Windows. I completely replaced my PC recently, this was happening on the old machine, it’s happening on the new one as well. I’ve done a factory reset for Blender Octane and only added the Octane plugin, still the same issue. No keys / settings modified. Current machine is 3950x, 64gb ram, rtx3090, windows 10

Since the hardware is completely different, I’m guessing this might be caused by some sort of setting / script that’s carried over from my previous Blender settings. I do use different versions of Blender, running different plugins and some custom hotkeys, but I’ve done no scripting or anything like that, just very basic customization. I’m thinking something that’s already installed must be interfering with the Octane plugin, but I have no idea what it could be.

This is from the log - it seems to repeat over and over.

Tried to access pin via an invalid ID P_UNKNOWN (0) Tried to access null node pin Can’t read bool from static pin ‘unknown’ (P_UNKNOWN, type PT_UNKNOWN) of node ‘’ (NT_UNKNOWN, 00007FFD9895D200) Tried to access pin via an invalid ID P_AI_LIGHT_STRENGTH (385) Tried to access null node pin Can’t read float from static pin ‘unknown’ (P_UNKNOWN, type PT_UNKNOWN) of node ‘’ (NT_UNKNOWN, 00007FFD9895D200) Tried to access pin via an invalid ID P_AI_LIGHT_STRENGTH (385) Tried to access null node pin Can’t write float to static pin ‘unknown’ (P_UNKNOWN, type PT_UNKNOWN) of node ‘’ (NT_UNKNOWN, 00007FFD9895D200) Tried to access pin via an invalid ID P_UNKNOWN (0) Tried to access null node pin

Any help would be very much appreciated, since the plugin is completely unusable in this state. Thank you so much for your help! :slight_smile:

Hi, I guess it is may better to post in the Octane forum, Blender section.
Does it work with the default cube?
Some have problems with the new AI light feature in the Blender Plugin, iirc.

Cheers, mib

Can’t post in the Blender section unfortunately, only in the general forums, which I’ve done, but I’m not sure if any of the tech people will see it there.

It doesn’t work with any scene, default cube or other geometry. No matter what the scene is, if I change to render mode, it immediately freezes.
The geo doesn’t seem to be the issue, getting to the render view with the Octane plugin is what seems to be the problem.
Tried it with the last 3 octane plugin versions, same result.
Thank you :slight_smile:

There are some Octane heads here but those issues are really hard to catch because it work for me for months on Windows and Linux with different hardware.
I use the free version of Blende for Octane now.
Please add your Octane version, OS and driver for other user to help.

Cheers, mib

Thanks, I’m doubting whether anyone could help since it does seem like a very particular problem, but you never know… :slight_smile:
Specs are in top post, I’ve bolded them now to make them more visible.
It’s the latest plugin version for Blender, with the latest Prime, tried the past 3 versions as well, same result. Windows 10, fresh install, latest NVIDIA drivers.

Oddly, I pretty much have the same specs as you (though with a 3700 cpu) and I’m currently experiecing the same issue. Was working absolutely fine up until yesterday.

Exact same issue. Was working perfectly fine, was using it regularly, then just suddenly started doing it. The only time it ever temporarily went away was when I installed a Windows update that also performed a refresh, essentially getting a fresh Windows install. Then it happened again.
On my new system though, with a fresh Windows install, it still happens. So I’m not sure if it’s an existing Blender installation that’s causing the issue or something else.

I’ve posted the same topic in 2 more locations - if anything comes up I’ll let you know :slight_smile:

thanks dude

it seems to be working fine today for some reason!

Have you tried turning off “use RTX acceleration”?

Yes, no difference unfortunately. I’ve restored to factory settings, only installed the Octane plugin, tried the RTX setting on and off, no difference. Thank you for the suggestion though.

@Oliver_Primus - happy it’s working for you again man :slight_smile: Hope it stays that way.

1 Like

Hi guys, same issue is happening to me, just suddenly after upgrading to MonterreyOS - my setup is very basic but it used to work fine. Now Octane Server just closes once I hit render or viewport render.

Still waiting to hear from Octane support… So if anyone knows anything about this please share.


Sometimes this happens with me if the texture nodes are in a bad state, connected incorrectly, etc. The newer plugin versions will now show a bad node connection by turning the noodle red. YMMV unfortunately.